summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:20 +0200
commit2c7365e7de7e269391f40086a7f3b7c8b827e259 (patch)
tree44ec873c25f2d50d5ab78c6924a0070a5d824447 /gnu/packages/tex.scm
parentb909fa8a61c2f02e8661daf73a6428c0fddcf079 (diff)
downloadguix-patches-2c7365e7de7e269391f40086a7f3b7c8b827e259.tar
guix-patches-2c7365e7de7e269391f40086a7f3b7c8b827e259.tar.gz
gnu: Add texlive-versions.
* gnu/packages/tex.scm (texlive-versions): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f96aa930b6..31dce0aef8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99412,6 +99412,25 @@ where significant chunks of text may be excluded.")
;; provided that the copyright notice and this permission is retained.
(license (license:fsf-free "file://tex/latex/version/version.sty"))))
+(define-public texlive-versions
+ (package
+ (name "texlive-versions")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/versions/" "tex/latex/versions/")
+ (base32
+ "1zq8vp85hsy8c6yjhpjslr8063q95w5rnyv23kkks44bkcgrac8l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/versions")
+ (synopsis "Optionally omit pieces of text")
+ (description
+ "Stephan Bellantoni's @code{version} has provided preamble commands for
+selecting environments to be included/excluded. This package does the same,
+but corrects, improves, and extends it in both implementation and function.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar