summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-05 13:47:32 +0200
committerChristopher Baines <mail@cbaines.net>2022-09-10 11:33:26 +0100
commit2411e0b0bb84a45c408a4e709cb11f76de467168 (patch)
tree7d57d05f228eb4ee41e2359532a0944cfac74a0e /gnu/packages/tex.scm
parenta53ef49baa6256a29dabb86c5d36f850f3838e2a (diff)
downloadguix-patches-2411e0b0bb84a45c408a4e709cb11f76de467168.tar
guix-patches-2411e0b0bb84a45c408a4e709cb11f76de467168.tar.gz
gnu: Add texlive-latex-marginfix.
* gnu/packages/tex.scm (texlive-latex-marginfix): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b3a81092db..0d0ff58f1b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5554,6 +5554,25 @@ always (re)defines a command. There is also @code{\\makeenvironment} and
@code{\\provideenvironment} for environments.")
(license license:lppl1.3c+)))
+(define-public texlive-latex-marginfix
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-marginfix"
+ (list "doc/latex/marginfix/"
+ "tex/latex/marginfix/")
+ (base32 "1qinf42mjry8bi5h3kgbi6hcymnk8fw0w43527wm95nc365dq0mf")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/marginfix")
+ (synopsis "Patch \\marginpar to avoid overfull margins")
+ (description
+ "Authors using LaTeX to typeset books with significant margin material
+often run into the problem of long notes running off the bottom of the page.
+This package implements a solution to make marginpars ``just work'' by keeping
+a list of floating inserts and arranging them intelligently in the output
+routine.")
+ (license license:lppl)))
+
(define-public texlive-metalogo
(package
(inherit (simple-texlive-package