summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 21:27:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:11 +0200
commit86af0f2a342269b9a3f6b8084a9e8e5d6feb6eb8 (patch)
treed48db1af345f06d8edda90d0ffa9db7466aee19d /gnu/packages/tex.scm
parentc178ffcaf2a203642c9c29f8f995cfc8c69857f7 (diff)
downloadguix-patches-86af0f2a342269b9a3f6b8084a9e8e5d6feb6eb8.tar
guix-patches-86af0f2a342269b9a3f6b8084a9e8e5d6feb6eb8.tar.gz
gnu: Add texlive-latex-preview.
* gnu/packages/tex.scm (texlive-latex-preview): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 331fb3453b..f8a79b9297 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2523,6 +2523,38 @@ previously had an alias “unicode”; that alias has now been withdrawn, and no
package of that name now exists.")
(license license:lppl1.3+)))
+(define-public texlive-latex-preview
+ (package
+ (name "texlive-latex-preview")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "preview"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0j6fff6q0ca96nwfdgay2jm55792z4q9aa0rczmiw2qccyg5n2dv"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/preview"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-generated-file
+ (lambda _
+ (delete-file "preview.drv")
+ #t)))))
+ (home-page "http://www.ctan.org/pkg/preview")
+ (synopsis "Extract bits of a LaTeX source for output")
+ (description
+ "The main purpose of the preview package is the extraction of selected
+elements from a LaTeX source, like formulas or graphics, into separate
+pages of a DVI file. A flexible and convenient interface allows it to
+specify what commands and constructs should be extracted. This works
+with DVI files postprocessed by either Dvips and Ghostscript or
+dvipng, but it also works when you are using PDFTeX for generating PDF
+files.")
+ (license license:gpl3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")