summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 11:57:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:37 +0200
commit406af0d66346565b62f94229dcbe8864acc5771c (patch)
tree4e390cdee902be01f883f2a80386fad2abb4dfd8 /gnu/packages/tex.scm
parentae3779d5cdd4b31a119d319d29a86c422383d765 (diff)
downloadguix-patches-406af0d66346565b62f94229dcbe8864acc5771c.tar
guix-patches-406af0d66346565b62f94229dcbe8864acc5771c.tar.gz
gnu: Add texlive-latex-lh.
* gnu/packages/tex.scm (texlive-latex-lh): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9841359223..afbfe6bb07 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2330,6 +2330,32 @@ styles. It also includes a package to change the page styles when there are
floats in a page. You may assign headers/footers to individual floats, too.")
(license license:lppl)))
+(define-public texlive-latex-lh
+ (package
+ (name "texlive-latex-lh")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "lh"))
+ (sha256
+ (base32
+ "00gdiwh3sfhh1iimjhpja7lm7k4vzqzql2irgwnpz94qvh25zwi5"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/lh"))
+ (home-page "http://www.ctan.org/pkg/lh")
+ (synopsis "Cyrillic fonts that support LaTeX standard encodings")
+ (description
+ "The LH fonts address the problem of the wide variety of alphabets that
+are written with Cyrillic-style characters. The fonts are the original basis
+of the set of T2* and X2 encodings that are now used when LaTeX users need to
+write in Cyrillic languages. Macro support in standard LaTeX encodings is
+offered through the latex-cyrillic and t2 bundles, and the package itself
+offers support for other (more traditional) encodings. The fonts, in the
+standard T2* and X2 encodings are available in Adobe Type 1 format, in the
+CM-Super family of fonts. The package also offers its own LaTeX support for
+OT2 encoded fonts, CM bright shaped fonts and Concrete shaped fonts.")
+ (license license:lppl)))
+
(define-public texlive-latex-wasysym
(package
(name "texlive-latex-wasysym")