summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-01 22:17:02 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-01 22:17:02 +0200
commitc5dd10b24ca2d55a1e97b8379aa3c3ebd13d7d0a (patch)
treeefad4b5d56e4b3eb5a7fc4f1dff8caa062ef5a59 /gnu/packages/tex.scm
parentd064cba7bfc051aa32816d5c64c466a52eaf6360 (diff)
downloadguix-patches-c5dd10b24ca2d55a1e97b8379aa3c3ebd13d7d0a.tar
guix-patches-c5dd10b24ca2d55a1e97b8379aa3c3ebd13d7d0a.tar.gz
gnu: Fix packages that were importing Guile modules from the host.
Those packages were importing (ice-9 match) & co. from the host Guile, which could potentially lead to different derivations depending on the Guile in use. Uncovered by the warning emitted by 'gexp-modules'. * gnu/packages/admin.scm (inxi-minimal)[arguments]: Remove Guile modules from #:modules. * gnu/packages/dns.scm (ddclient)[arguments]: Likewise. * gnu/packages/tex.scm (texlive-latex-koma-script)[arguments]: Likewise. * gnu/packages/java.scm (openjdk11)[arguments]: Likewise for #:imported-modules.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d90e41c533..6a90ba0821 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7098,8 +7098,7 @@ produce either PostScript or PDF output.")
"1vz9zg7s5w52xr323zgglzprfrvba2zvyzf6b8vrdf4wdghlpv4z"))))
(build-system trivial-build-system)
(arguments
- `(#:modules ((guix build utils)
- (ice-9 match))
+ `(#:modules ((guix build utils))
#:builder
(begin
(use-modules (guix build utils)