summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-02 23:04:57 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 09:02:12 -0500
commit9e78ea79f81d9eec0fab9cbe204899e384973649 (patch)
tree21feae618ffb559183436b1bb32cda942400a7d9 /gnu/packages/tex.scm
parentec14d5f7294a2776e288ccab74221b50fe653cad (diff)
downloadguix-patches-9e78ea79f81d9eec0fab9cbe204899e384973649.tar
guix-patches-9e78ea79f81d9eec0fab9cbe204899e384973649.tar.gz
gnu: texlive-bin: Fix the tlmgr utility.
Previously, it would error out, not finding its Perl modules, and later not finding config.guess. This utility is useful to query the local TeX Live package database (texlive.tlpdb). (texlive-bin)[inputs]{config}: New input. [phases]{postint}: Add a symlink to the 'config.guess' script. Patch the tlmgr.pl script so that it can find its Perl modules and other resources.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3f17bf4458..4a4184c338 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -279,6 +279,7 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(build-system gnu-build-system)
(inputs
`(("texlive-extra-src" ,texlive-extra-src)
+ ("config" ,config)
("texlive-scripts"
,(origin
(method svn-fetch)
@@ -452,6 +453,16 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(("\\$TEXMFROOT/")
(string-append share "/")))
+ ;; Likewise for the tlmgr.
+ (substitute* (string-append scripts "/tlmgr.pl")
+ ((".*\\$::installerdir = \\$Master.*" all)
+ (format #f " $Master = ~s;~%~a" share all)))
+
+ ;; Install the config.guess script, required by tlmgr.
+ (with-directory-excursion share
+ (mkdir-p "tlpkg/installer/")
+ (symlink config.guess "tlpkg/installer/config.guess"))
+
;; texlua shebangs are not patched by the patch-source-shebangs
;; phase because the texlua executable does not exist at that
;; time.