summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-06 21:53:32 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 22:02:15 +0200
commitb949f34f31a045eb0fb242b81a223178fb6994d3 (patch)
tree837a94d9d642039f46ce071b8ac1adbb805b3a71 /gnu/packages/tex.scm
parent3dc8052b51241fe7857059d3300dad3a0f9f68fd (diff)
downloadguix-patches-b949f34f31a045eb0fb242b81a223178fb6994d3.tar
guix-patches-b949f34f31a045eb0fb242b81a223178fb6994d3.tar.gz
gnu: Use the non-deprecated TeX packages.
This commit leaves 'dblatex' and 'texlive-hyperref' as users of deprecated packages, but these have many dependents. * gnu/packages/bioinformatics.scm (discrover)[native-inputs]: Use non-deprecated TeX Live packages. (velvet)[native-inputs]: Likewise. * gnu/packages/chez.scm (chez-scheme)[native-inputs]: Likewise. (chez-web)[native-inputs]: Likewise. * gnu/packages/engineering.scm (fastcap)[native-inputs]: Likewise. * gnu/packages/guile-xyz.scm (emacsy)[native-inputs]: Likewise. * gnu/packages/maths.scm (hypre)[native-inputs]: Likewise. * gnu/packages/music.scm (lilypond)[native-inputs]: Likewise. * gnu/packages/ocaml.scm (ocaml-bibtex2html)[native-inputs]: Likewise. * gnu/packages/plotutils.scm (asymptote)[native-inputs]: Likewise. * gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]: Likewise. (python-matplotlib-documentation)[native-inputs]: Likewise. (python-ipython-documentation)[native-inputs]: Likewise. (python-nbconvert)[native-inputs]: Likewise. (python-pypandoc)[native-inputs]: Likewise. * gnu/packages/statistics.scm (r-with-tests)[native-inputs]: Likewise. * gnu/packages/tex.scm (texlive-pstool)[propagated-inputs]: Likewise. (teximpatient)[native-inputs]: Likewise. (texlive-latex-pgf)[propagated-inputs]: Likewise. (texlive-beamer)[propagated-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c2846793b2..58732462ae 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4563,7 +4563,7 @@ rotated.")
#:trivial? #t))
(propagated-inputs
`(("texlive-latex-bigfoot" ,texlive-latex-bigfoot) ; for suffix
- ("texlive-latex-filemod" ,texlive-latex-filemod)
+ ("texlive-filemod" ,texlive-filemod)
("texlive-latex-graphics" ,texlive-latex-graphics)
("texlive-latex-ifplatform" ,texlive-latex-ifplatform)
("texlive-latex-l3kernel" ,texlive-latex-l3kernel) ; for expl3
@@ -7134,10 +7134,10 @@ develop documents with LaTeX, in a single application.")
#t)))))
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
- texlive-fonts-adobe-palatino
- texlive-fonts-adobe-zapfding
+ texlive-palatino
+ texlive-zapfding
texlive-knuth-lib
- texlive-fonts-mflogo-font
+ texlive-mflogo-font
texlive-pdftex)))
("automake" ,automake)))
(home-page "https://www.gnu.org/software/teximpatient/")
@@ -7487,7 +7487,7 @@ striking out (line through words) and crossing out (/// over words).")
(base32
"05zdq7y3am109m5534ahqqp9x5iar3ha68v1r4zkrdly2mijxz2j"))))))
(propagated-inputs
- `(("texlive-latex-xcolor" ,texlive-latex-xcolor)))
+ `(("texlive-xcolor" ,texlive-xcolor)))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -8119,9 +8119,9 @@ for a wealth of support information.")
"091n27n4l3iac911bvmpp735ffryyzaq46mkclgn3q9jsvc4ngiv")
#:trivial? #t))
(propagated-inputs
- `(("texlive-latex-hyperref" ,texlive-latex-hyperref)
+ `(("texlive-hyperref" ,texlive-hyperref)
("texlive-oberdiek" ,texlive-oberdiek)
- ("texlive-latex-etoolbox" ,texlive-latex-etoolbox)
+ ("texlive-etoolbox" ,texlive-etoolbox)
("texlive-latex-pgf" ,texlive-latex-pgf)))
(home-page "https://www.ctan.org/pkg/beamer")
(synopsis "LaTeX class for producing presentations and slides")