summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-25 23:35:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-23 10:10:57 +0100
commit556aca82a38d856d3ef75a8399ab0f0bd95f5b1d (patch)
tree4da8aca725bf3dfc735e048f6b46190ed6a78985 /gnu/packages/tex.scm
parentd08f54ec4ced25958486df2baf5fbd7ec5937981 (diff)
downloadguix-patches-556aca82a38d856d3ef75a8399ab0f0bd95f5b1d.tar
guix-patches-556aca82a38d856d3ef75a8399ab0f0bd95f5b1d.tar.gz
gnu: texlive-luatex-luaotfload: Use TeX Live sources.
* gnu/packages/tex.scm (texlive-luatex-luaotfload): Deprecate in favor of... (texlive-luaotfload): ...this new variable; install files from the TeX Live repository.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm115
1 files changed, 28 insertions, 87 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a6db1fb7a8..1e6188d292 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3139,97 +3139,38 @@ this bundle for use independent of ConTeXt.")
;; GPL version 2 only
(license license:gpl2)))
-(define-public texlive-luatex-luaotfload
- (package
- (name "texlive-luatex-luaotfload")
- (version "2.8-fix-2")
- ;; The release tarball does not contain all source files.
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lualatex/luaotfload")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0l5l7iq3dxcxl65qaghcpjg27yd9iw1sxa8pnd7xlvlm09dhfdnf"))))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags
- (list (string-append "DESTDIR="
- (assoc-ref %outputs "out")
- "/share/texmf-dist")
- "all")
- #:parallel-build? #f ; not supported
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "doc/Makefile"
- (("rst2man") "rst2man.py")
- ;; Don't build the PDF. This requires more of LaTeX.
- (("\\$\\(DOCPDF\\)") ""))
-
- (substitute* "Makefile"
- ;; We don't build the PDF, so don't attempt to install it.
- (("cp \\$\\(RESOURCES\\) \\$\\(DOCPDF\\)")
- "cp $(RESOURCES)")
- (("= \\$\\(DOCPDF\\)") "= ")
- ;; Fix name of fontloader file
- (("^LOADER.*= \\$\\(BUILDDIR\\)/fontloader-\\$\\(shell date \\+%F\\).lua")
- "LOADER = $(BUILDDIR)/fontloader.lua"))
-
- (mkdir "build")
-
- ;; Don't download this file.
- (copy-file (assoc-ref inputs "glyphlist")
- "build/glyphlist.txt")
-
- ;; Don't use git
- (let ((notes
- `((committer . "Philipp Gesang <phg@phi-gamma.net>")
- (description . ,version)
- (loader . "fontloader.lua")
- (revision . "ad480924393fffa2896156e1a32c22f5c61120dd")
- (timestamp . "2019-01-01 00:00:00 +0000"))))
- (substitute* "scripts/mkstatus"
- (("local notes.*=.*")
- (string-append "local notes = {"
- (string-join
- (map (lambda (entry)
- (format "[\"~a\"]=\"~a\","
- (symbol->string (car entry))
- (cdr entry)))
- notes))
- "}"))))
- #t)))))
- (native-inputs
- `(("zip" ,zip)
- ("unzip" ,unzip)
- ("graphviz" ,graphviz)
- ("lualatex" ,(texlive-union (list texlive-luatex-lualibs
- texlive-context-base)))
- ("python-docutils" ,python-docutils)
- ("glyphlist"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://raw.githubusercontent.com/adobe-type-tools/"
- "agl-aglfn/b2a04cb906f9257cc06a2fe0ad4b3d663bc02136/"
- "glyphlist.txt"))
- (sha256
- (base32 "1s6svfw23rqzdvflv8frgd4xrwvrmsj8szwzqgcd39dp9rpjafjp"))))))
- (propagated-inputs
- `(("texlive-luatex-lualibs" ,texlive-luatex-lualibs)))
- (home-page "https://github.com/lualatex/luaotfload")
- (synopsis "OpenType font loader for LuaTeX")
- (description
- "Luaotfload is an adaptation of the ConTeXt font loading system for the
+;; TODO: We should be able to build this from the sources on Github with
+;; texlive-l3build, but I haven't been able to get it to work.
+(define-public texlive-luaotfload
+ (let ((template (simple-texlive-package
+ "texlive-luaotfload"
+ (list "/doc/luatex/luaotfload/"
+ "/doc/man/man1/luaotfload-tool.1"
+ "/doc/man/man5/luaotfload.conf.5"
+ "/source/luatex/luaotfload/fontloader-reference-load-order.lua"
+ "/source/luatex/luaotfload/fontloader-reference-load-order.tex"
+ "/scripts/luaotfload/luaotfload-tool.lua"
+ "/tex/luatex/luaotfload/")
+ (base32
+ "04xlcc9k56kf9460dzxifnxbv5bkv7kcp9ijiqi054miybw1pymr")
+ #:trivial? #t)))
+ (package
+ (inherit template)
+ (propagated-inputs
+ `(("texlive-luatex-lualibs" ,texlive-luatex-lualibs)))
+ (home-page "https://github.com/lualatex/luaotfload")
+ (synopsis "OpenType font loader for LuaTeX")
+ (description
+ "Luaotfload is an adaptation of the ConTeXt font loading system for the
Plain and LaTeX formats. It allows OpenType fonts to be loaded with font
features accessible using an extended font request syntax while providing
compatibilitywith XeTeX. By indexing metadata in a database it facilitates
loading fonts by their proper names instead of file names.")
- ;; GPL version 2 only
- (license license:gpl2)))
+ ;; GPL version 2 only
+ (license license:gpl2))))
+
+(define-public texlive-luatex-luaotfload
+ (deprecated-package "texlive-luatex-luaotfload" texlive-luaotfload))
(define-public texlive-latex-amsmath
(package