summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:55:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:44 +0200
commita14ffed231139618572d5063799806c423849f51 (patch)
tree5574a87217f554dfee936b7ed3a00db3a6bf7add /gnu/packages/tex.scm
parentbac10d8224ac759fa38f214c9741c58c84d4da24 (diff)
downloadguix-patches-a14ffed231139618572d5063799806c423849f51.tar
guix-patches-a14ffed231139618572d5063799806c423849f51.tar.gz
gnu: Add texlive-hyphen-french.
* gnu/packages/tex.scm (texlive-hyphen-french): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index afca3461c4..f68fffd3a1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1708,6 +1708,18 @@ be replaced by files tailored to individual languages.")
T1/EC and UTF-8 encodings.")
(license license:public-domain)))
+(define-public texlive-hyphen-french
+ (package
+ (inherit (texlive-hyphen-package
+ "texlive-hyphen-french" "fr"
+ (list "/tex/generic/hyph-utf8/patterns/tex/hyph-fr.tex")
+ (base32
+ "1q82mmwvy7fdkm42958ajb53w89qkcdwybswxlwcvqngvhpy3zf0")))
+ (synopsis "Hyphenation patterns for French")
+ (description "The package provides hyphenation patterns for French in
+T1/EC and UTF-8 encodings.")
+ (license license:expat)))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package