summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:55:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:44 +0200
commit8d87184b1210d2a46026898b72c803ea5d6d9175 (patch)
tree39bd5fd98f2edc9ce17e6220f515abcf04633083 /gnu/packages/tex.scm
parent28fbf42ae5c70ec2527af14d6c1446b9937b9923 (diff)
downloadguix-patches-8d87184b1210d2a46026898b72c803ea5d6d9175.tar
guix-patches-8d87184b1210d2a46026898b72c803ea5d6d9175.tar.gz
gnu: Add texlive-hyphen-galician.
* gnu/packages/tex.scm (texlive-hyphen-galician): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 03ca8a4ca6..838a28e88f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1732,6 +1732,54 @@ T1/EC and UTF-8 encodings.")
ASCII encodings.")
(license license:lppl1.3+)))
+(define-public texlive-hyphen-galician
+ (let ((template (texlive-hyphen-package
+ "texlive-hyphen-galician" "gl"
+ (list "/source/generic/hyph-utf8/languages/gl/README"
+ "/source/generic/hyph-utf8/languages/gl/glhybiox.tex"
+ "/source/generic/hyph-utf8/languages/gl/glhyextr.tex"
+ "/source/generic/hyph-utf8/languages/gl/glhymed.tex"
+ "/source/generic/hyph-utf8/languages/gl/glhyquim.tex"
+ "/source/generic/hyph-utf8/languages/gl/glhytec.tex"
+ "/source/generic/hyph-utf8/languages/gl/glhyxeog.tex"
+ "/source/generic/hyph-utf8/languages/gl/glpatter-utf8.tex")
+ (base32
+ "1yj1gxhkqqlyaand5gd6ij6xwffskryzlbcigdam3871a9p8x18w"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'build 'build-patterns
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tex (string-append (getcwd)
+ "/tex/generic/hyph-utf8/patterns/tex/")))
+ (mkdir-p tex)
+ (with-directory-excursion "source/generic/hyph-utf8/languages/gl/"
+ (setenv "TEXINPUTS"
+ (string-append (getcwd) "//:"
+ (assoc-ref inputs "texlive-mkpattern") "//"))
+ (invoke "tex" "-ini" "-8bit" "glpatter-utf8.tex")
+ (rename-file "hyph-gl.tex"
+ (string-append tex "/hyph-gl.tex"))
+ #t))))
+ (add-after 'install 'install-hyph-gl.tex
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (target (string-append out "/share/texmf-dist/tex")))
+ (copy-recursively "tex" target)
+ #t)))))))
+ (native-inputs
+ `(,@(package-native-inputs template)
+ ("texlive-bin" ,texlive-bin)
+ ("texlive-mkpattern" ,texlive-mkpattern)))
+ (synopsis "Hyphenation patterns for Galician")
+ (description "The package provides hyphenation patterns for Galician in
+T1/EC and UTF-8 encodings.")
+ ;; glhyextr.tex is the only file in the public domain.
+ (license (list license:lppl1.3 license:public-domain)))))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package