summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:55:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:44 +0200
commit54ef221c59085723990d4df3234f10862acc7e67 (patch)
tree3b7e86520a5da0b4039d4b90a427d97e5bc834b0 /gnu/packages/tex.scm
parent5f2294843cbf92cf5144423a7206c04af1ae4353 (diff)
downloadguix-patches-54ef221c59085723990d4df3234f10862acc7e67.tar
guix-patches-54ef221c59085723990d4df3234f10862acc7e67.tar.gz
gnu: Add texlive-hyphen-ethiopic.
* gnu/packages/tex.scm (texlive-hyphen-ethiopic): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3a22eb3f90..b6048b2d1d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1645,6 +1645,57 @@ T1/EC and UTF-8 encodings.")
;; Dual licensed under either license.
(license (list license:lppl1.3+ license:expat))))
+(define-public texlive-hyphen-ethiopic
+ (let ((template (texlive-hyphen-package
+ "texlive-hyphen-ethiopic" "mul-ethi"
+ (list "/source/generic/hyph-utf8/languages/mul-ethi/generate_patterns_mul-ethi.lua")
+ (base32
+ "1dp5qn1mhv62kj27lqc7s0ca65z9bziyavkvif9ds5ivk7aq9drw"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'build 'build-patterns
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((tex (string-append (getcwd)
+ "/tex/generic/hyph-utf8/patterns/tex/")))
+ (mkdir-p tex)
+ (with-directory-excursion "source/generic/hyph-utf8/languages/mul-ethi/"
+ (substitute* "generate_patterns_mul-ethi.lua"
+ (("\"UnicodeData.txt\"")
+ (string-append "\""
+ (assoc-ref inputs "UnicodeData.txt")
+ "\"")))
+ (invoke "texlua" "generate_patterns_mul-ethi.lua")
+ (rename-file "hyph-mul-ethi.tex"
+ (string-append tex "/hyph-mul-ethi.tex"))
+ #t))))
+ (add-after 'install 'install-hyph-mul-ethi.tex
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (target (string-append out "/share/texmf-dist/tex")))
+ (copy-recursively "tex" target)
+ #t)))))))
+ (native-inputs
+ `(,@(package-native-inputs template)
+ ("texlive-bin" ,texlive-bin)
+ ("UnicodeData.txt"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "http://www.unicode.org/Public/10.0.0/ucd/"
+ "UnicodeData.txt"))
+ (sha256
+ (base32
+ "1cfak1j753zcrbgixwgppyxhm4w8vda8vxhqymi7n5ljfi6kwhjj"))))))
+ (synopsis "Hyphenation patterns for Ethiopic scripts")
+ (description "The package provides hyphenation patterns for languages
+written using the Ethiopic script for Unicode engines. They are not supposed
+to be linguistically relevant in all cases and should, for proper typography,
+be replaced by files tailored to individual languages.")
+ (license license:lppl))))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package