summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-05 00:09:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-14 09:02:09 -0500
commit60f128c20bd7062a857f674bbcb3ca74ca670979 (patch)
tree3ea3e6fe194fd8317d0c5c2ead8d569f43e3dab7 /gnu/packages/tex.scm
parent8d44bb85fef9a8cd7ef86b462ef755431f7a45fd (diff)
downloadguix-patches-60f128c20bd7062a857f674bbcb3ca74ca670979.tar
guix-patches-60f128c20bd7062a857f674bbcb3ca74ca670979.tar.gz
gnu: texlive-latex-oberdiek: Rename to texlive-oberdiek.
This is done to match the package name as registered in the texlive.tlpdb database. * gnu/packages/tex.scm (texlive-latex-oberdiek): New deprecated package. (texlive-oberdiek): Renamed from the above. (texlive-pstool, texlive-latex-geometry) (texlive-beamer): Adjust to use the renamed package variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 704f550c3d..84fcb81f7a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2866,7 +2866,7 @@ tables.")
(add-after 'unpack 'chdir
(lambda _ (chdir "source/latex/hyperref") #t))))))
(propagated-inputs
- `(("texlive-latex-oberdiek" ,texlive-latex-oberdiek) ; for ltxcmds.sty
+ `(("texlive-oberdiek" ,texlive-oberdiek) ; for ltxcmds.sty
("texlive-latex-url" ,texlive-latex-url)))
(home-page "https://www.ctan.org/pkg/hyperref")
(synopsis "Extensive support for hypertext in LaTeX")
@@ -2884,9 +2884,9 @@ pdf and HTML backends. The package is distributed with the @code{backref} and
(define-public texlive-latex-hyperref
(deprecated-package "texlive-latex-hyperref" texlive-hyperref))
-(define-public texlive-latex-oberdiek
+(define-public texlive-oberdiek
(package
- (name "texlive-latex-oberdiek")
+ (name "texlive-oberdiek")
(version (number->string %texlive-revision))
(source (origin
(method svn-fetch)
@@ -2917,6 +2917,9 @@ better accessibility support for PDF files; extensible chemists reaction
arrows; record information about document class(es) used; and many more.")
(license license:lppl1.3+)))
+(define-public texlive-latex-oberdiek
+ (deprecated-package "texlive-latex-oberdiek" texlive-oberdiek))
+
(define-public texlive-latex-tools
(package
(name "texlive-latex-tools")
@@ -4058,7 +4061,7 @@ rotated.")
("texlive-latex-graphics" ,texlive-latex-graphics)
("texlive-latex-ifplatform" ,texlive-latex-ifplatform)
("texlive-latex-l3kernel" ,texlive-latex-l3kernel) ; for expl3
- ("texlive-latex-oberdiek" ,texlive-latex-oberdiek)
+ ("texlive-oberdiek" ,texlive-oberdiek)
("texlive-latex-psfrag" ,texlive-latex-psfrag)
("texlive-latex-tools" ,texlive-latex-tools) ; for shellesc
("texlive-latex-trimspaces" ,texlive-latex-trimspaces)
@@ -4375,7 +4378,7 @@ BibLaTeX, and is considered experimental.")
(build-system texlive-build-system)
(arguments '(#:tex-directory "latex/geometry"))
(propagated-inputs
- `(("texlive-latex-oberdiek" ,texlive-latex-oberdiek))) ;for ifpdf
+ `(("texlive-oberdiek" ,texlive-oberdiek))) ;for ifpdf
(home-page "https://www.ctan.org/pkg/geometry")
(synopsis "Flexible and complete interface to document dimensions")
(description
@@ -7151,7 +7154,7 @@ for a wealth of support information.")
#:trivial? #t))
(propagated-inputs
`(("texlive-latex-hyperref" ,texlive-latex-hyperref)
- ("texlive-latex-oberdiek" ,texlive-latex-oberdiek)
+ ("texlive-oberdiek" ,texlive-oberdiek)
("texlive-latex-etoolbox" ,texlive-latex-etoolbox)
("texlive-latex-pgf" ,texlive-latex-pgf)))
(home-page "https://www.ctan.org/pkg/beamer")