summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 17:55:08 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:52 +0200
commite30373f8ac458390a7ed5bfb12be84f6039dee1a (patch)
treef94c65cd799ff0babfe5794fbab296b8b7f0c77d /gnu/packages/tex.scm
parent95e3a20985d9427fce9ce9bc5a2c4fe43ccc7190 (diff)
downloadguix-patches-e30373f8ac458390a7ed5bfb12be84f6039dee1a.tar
guix-patches-e30373f8ac458390a7ed5bfb12be84f6039dee1a.tar.gz
gnu: Add texlive-generic-gettitlestring.
* gnu/packages/tex.scm (texlive-generic-gettitlestring): New public variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3cc345e018..3e40144ab7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7360,6 +7360,23 @@ adding a prefix to e-TeX’s commands. For example, ε-TeX’s
@code{\\unexpanded} is provided as @code{\\etex@unexpanded}.")
(license license:lppl1.3c+)))
+(define-public texlive-generic-gettitlestring
+ (package
+ (inherit (simple-texlive-package
+ "texlive-generic-gettitlestring"
+ '("/doc/latex/gettitlestring/"
+ "/tex/generic/gettitlestring/")
+ (base32
+ "1p4hg9mac03rzvj9dw0ws3zdh55fy1ns954f912algw9f2aq4xgp")
+ #:trivial? #t))
+ (home-page "https://www.ctan.org/pkg/gettitlestring")
+ (synopsis "Clean up title references")
+ (description
+ "This package provides commands for cleaning up the title string
+(such as removing @code{\\label} commands) for packages that typeset such
+strings.")
+ (license license:lppl1.3c+)))
+
(define-public texlive-generic-infwarerr
(package
(inherit (simple-texlive-package