summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
committerMark H Weaver <mhw@netris.org>2016-08-04 08:16:38 -0400
commit0832787e5c463c713d8f24fdec0f52900ff1c2bd (patch)
tree5ce20bef711d0d85a22cd041758278d7c176b0f3 /gnu/packages/tex.scm
parent5b098cc4b937c05d6f685772c66e2aa04490710a (diff)
downloadguix-patches-0832787e5c463c713d8f24fdec0f52900ff1c2bd.tar
guix-patches-0832787e5c463c713d8f24fdec0f52900ff1c2bd.tar.gz
Revert "Merge branch 'core-updates'"
This reverts commit 455859a50f88f625d13fc2f304111f02369b366b.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9dde8a9eab..4350fefa2e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4,7 +4,6 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016 Federico Beffa <beffa@fbengineering.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -187,11 +186,6 @@ This package contains the binaries.")
`(#:modules ((guix build gnu-build-system)
(guix build utils)
(srfi srfi-26))
-
- ;; This package takes 4 GiB, which we can't afford to distribute from
- ;; our servers.
- #:substitutable? #f
-
#:phases
(modify-phases (map (cut assq <> %standard-phases)
'(set-paths unpack patch-source-shebangs))
@@ -212,10 +206,7 @@ This package contains the binaries.")
;; Register SHARE as TEXMFROOT in texmf.cnf.
(substitute* texmfcnf
(("TEXMFROOT = \\$SELFAUTOPARENT")
- (string-append "TEXMFROOT = " share))
- (("TEXMFLOCAL = \\$SELFAUTOGRANDPARENT/texmf-local")
- "TEXMFLOCAL = $SELFAUTODIR/share/texmf-local")
- (("!!\\$TEXMFLOCAL") "$TEXMFLOCAL"))
+ (string-append "TEXMFROOT = " share)))
;; Register paths in texmfcnf.lua, needed for context.
(substitute* (string-append texmfroot "/texmfcnf.lua")
(("selfautodir:") out)
@@ -251,10 +242,6 @@ This package contains the complete tree of texmf-dist data.")
(inputs `(("bash" ,bash) ; for wrap-program
("texlive-bin" ,texlive-bin)
("texlive-texmf" ,texlive-texmf)))
- (native-search-paths
- (list (search-path-specification
- (variable "TEXMFLOCAL")
- (files '("share/texmf-local")))))
(arguments
`(#:modules ((guix build utils))
#:builder
@@ -306,8 +293,7 @@ This package contains the complete TeX Live distribution.")
;; texlive-texmf-minimal is a pruned, small version of the texlive tree,
-;; in particular dropping documentation and fonts. It weighs in at 470 MiB
-;; instead of 4 GiB.
+;; in particular dropping documentation and fonts.
(define texlive-texmf-minimal
(package (inherit texlive-texmf)
(name "texlive-texmf-minimal")
@@ -367,10 +353,6 @@ This package contains a small subset of the texmf-dist data.")))
(inputs
`(("texlive-texmf" ,texlive-texmf-minimal)
,@(alist-delete "texlive-texmf" (package-inputs texlive))))
- (native-search-paths
- (list (search-path-specification
- (variable "TEXMFLOCAL")
- (files '("share/texmf-local")))))
(description
"TeX Live provides a comprehensive TeX document production system.
It includes all the major TeX-related programs, macro packages, and fonts