summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNathan Benedetto Proença <nathan@vieiraproenca.com>2021-07-09 10:45:16 -0300
committerLudovic Courtès <ludo@gnu.org>2021-07-21 15:59:29 +0200
commitc3e33474b965ac1b7d91b69b026630e7c707e289 (patch)
tree015ba7d3359293bf31560503edb80a1310dfe8e8 /gnu/packages/tex.scm
parent313c69a10008f9f794163970930f6e74e651ed24 (diff)
downloadguix-patches-c3e33474b965ac1b7d91b69b026630e7c707e289.tar
guix-patches-c3e33474b965ac1b7d91b69b026630e7c707e289.tar.gz
gnu: biber: Update to 2.16.
* gnu/packages/tex.scm (biber): Update to 2.16. [source]: Remove 'patches'. [inputs]: Add 'perl-io-string', 'perl-parse-recdescent', and 'perl-unicode-collate' (upstream appears to have fixed the issue initially mentioned as a comment: recent issue was closed after telling user to use perl-unicode-collate 1.29, which is the one available; see <https://github.com/plk/biber/issues/378>.) * gnu/packages/patches/biber-fix-encoding-write.patch, gnu/packages/patches/biber-sortinithash.patch: Remove. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm15
1 files changed, 5 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f8eb3e80d5..681a1aa972 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6966,20 +6966,16 @@ values (strings, macros, or numbers) pasted together.")
;; checking the Biber/BibLaTeX compatibility matrix in the BibLaTeX manual
;; at <https://ctan.org/pkg/biblatex>.
(name "biber")
- (version "2.12")
+ (version "2.16")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/plk/biber/")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- ;; TODO: Patch awaiting inclusion upstream (see:
- ;; https://github.com/plk/biber/issues/239).
- (patches (search-patches "biber-fix-encoding-write.patch"
- "biber-sortinithash.patch"))
(sha256
(base32
- "1g1hi6zvf2hmrjly1sidjaxy5440gfqm4p7p3n7kayshnjsmlskx"))))
+ "0586q8y1f2k23mvb02ccm3qsb35cwskafksixsjaih7a7xcf5gxx"))))
(build-system perl-build-system)
(arguments
`(#:phases
@@ -7002,6 +6998,7 @@ values (strings, macros, or numbers) pasted together.")
("perl-datetime-format-builder" ,perl-datetime-format-builder)
("perl-datetime-calendar-julian" ,perl-datetime-calendar-julian)
("perl-file-slurper" ,perl-file-slurper)
+ ("perl-io-string" ,perl-io-string)
("perl-ipc-cmd" ,perl-ipc-cmd)
("perl-ipc-run3" ,perl-ipc-run3)
("perl-list-allutils" ,perl-list-allutils)
@@ -7009,10 +7006,8 @@ values (strings, macros, or numbers) pasted together.")
("perl-mozilla-ca" ,perl-mozilla-ca)
("perl-regexp-common" ,perl-regexp-common)
("perl-log-log4perl" ,perl-log-log4perl)
- ;; We cannot use perl-unicode-collate here, because otherwise the
- ;; hardcoded hashes in the tests would differ. See
- ;; https://mail-archive.com/debian-bugs-dist@lists.debian.org/msg1469249.html
- ;;("perl-unicode-collate" ,perl-unicode-collate)
+ ("perl-parse-recdescent" ,perl-parse-recdescent)
+ ("perl-unicode-collate" ,perl-unicode-collate)
("perl-unicode-normalize" ,perl-unicode-normalize)
("perl-unicode-linebreak" ,perl-unicode-linebreak)
("perl-encode-eucjpascii" ,perl-encode-eucjpascii)