summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-07-10 14:36:54 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-07-10 15:01:59 +0200
commitf7f6cbb6b68fd88543097bb69b992a86043499ce (patch)
treea334803679965a61fc8d1005531bf1090cd938ea /gnu/packages/tex.scm
parentbfa0df0d612b745b97c0785c31e76e8cde58657d (diff)
downloadguix-patches-f7f6cbb6b68fd88543097bb69b992a86043499ce.tar
guix-patches-f7f6cbb6b68fd88543097bb69b992a86043499ce.tar.gz
gnu: Add texlive-preprint.
* gnu/packages/tex.scm (texlive-preprint): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8afa18a7fd..8d86264209 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Leo Le Bouter <lle-bout@zaclys.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
+;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8118,6 +8119,30 @@ shape axis and it adds three new axes to deal with the different
figure versions offered by many professional fonts.")
(license license:lppl1.3+)))
+(define-public texlive-preprint
+ (package
+ (name "texlive-preprint")
+ (version "1.0e")
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "preprint"))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "173ik9xad3zih6gcdwdkzyljarh06ky6c5d2x1yjs22qqi75py5a"))))
+ (build-system texlive-build-system)
+ (arguments '(#:tex-directory "latex/preprint"))
+ (home-page "http://www.ctan.org/pkg/preprint")
+ (synopsis "Bundle of modules for preprints")
+ (description "The bundle comprises: @code{authblk}, which permits
+footnote style author/affiliation input in the @command{\\author} command,
+@code{balance}, to balance the end of @command{\\twocolumn} pages,
+@code{figcaps}, to send figure captions, etc., to end document,
+@code{fullpage}, to set narrow page margins and set a fixed page style, and
+@code{sublabel}, which permits counters to be subnumbered.")
+ (license license:lppl1.3+)))
+
(define-public texlive-mweights
(package
(inherit (simple-texlive-package