summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-12 23:54:43 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-13 09:32:58 +0000
commita93f7a2ee30a1bce3e5518b01938b6b6968137fd (patch)
tree56922f3b4b3011ddd4984d3d68bcd5234fa9dfec /gnu/packages/tex.scm
parentc887cfb2d0c3991e5007df49370db8c303cacfdb (diff)
downloadguix-patches-a93f7a2ee30a1bce3e5518b01938b6b6968137fd.tar
guix-patches-a93f7a2ee30a1bce3e5518b01938b6b6968137fd.tar.gz
gnu: Add texlive-stringenc.
* gnu/packages/tex.scm (texlive-stringenc): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2e2320b091..d563019a09 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3589,6 +3589,45 @@ LaTeX code now supports multiple dots and spaces, and this package by default
is a stub that just loads @code{graphicx}.")
(license license:lppl1.3c+))))
+(define-public texlive-stringenc
+ (let ((template (simple-texlive-package
+ "texlive-stringenc"
+ (list "/doc/latex/stringenc/README.md"
+ "/source/latex/stringenc/stringenc.dtx")
+ (base32
+ "19sfi5jxldxmy79pxmapmgmn3iknf8wjczasvlrrwv0gyycxdzhw"))))
+ (package
+ (inherit template)
+ (outputs '("doc" "out"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "generic/stringenc")
+ ((#:build-targets _ #t)
+ '(list "stringenc.dtx"))
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/stringenc/")))
+ (add-after 'copy-files 'clean-up
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/share/texmf-dist/build"))
+ (delete-file
+ (string-append (assoc-ref outputs "out") "/share/texmf-dist/stringenc.dtx"))
+ (install-file
+ (string-append (assoc-ref inputs "source") "/source/latex/stringenc/stringenc.dtx")
+ (string-append (assoc-ref outputs "out") "/share/texmf-dist/source/latex/stringenc/"))
+ (install-file
+ (string-append (assoc-ref inputs "source") "/doc/latex/stringenc/README.md")
+ (string-append (assoc-ref outputs "doc") "/doc/latex/stringenc/"))))))))
+ (home-page "https://www.ctan.org/pkg/stringenc")
+ (synopsis "Converting a string between different encodings")
+ (description
+ "This package provides @code{\\StringEncodingConvert} for converting a
+string between different encodings. Both LaTeX and plain-TeX are supported.")
+ (license license:lppl1.3c+))))
+
(define-public texlive-l3build
(let ((template (simple-texlive-package
"texlive-l3build"