summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-16 14:06:41 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-16 14:38:02 +0100
commit9bbbac6783bcdace17d967e85c8ae8d14cbf1ef9 (patch)
tree68ba67c5b9312015a256576ed979718ef31ec0c8 /gnu/packages/tex.scm
parente699eb3bccab17cd24ca57ce27e3544c9a8927fc (diff)
downloadguix-patches-9bbbac6783bcdace17d967e85c8ae8d14cbf1ef9.tar
guix-patches-9bbbac6783bcdace17d967e85c8ae8d14cbf1ef9.tar.gz
gnu: Add texlive-latex-textpos.
* gnu/packages/tex.scm (texlive-latex-textpos): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba959b8191..ed171475ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8851,6 +8851,30 @@ language preferred by the user. This package is not intended to be used to
automatically translate more than a few words.")
(license (list license:lppl license:gpl1+))))
+(define-public texlive-latex-textpos
+ (package
+ (inherit (simple-texlive-package
+ "texlive-latex-textpos"
+ (list "doc/latex/textpos/"
+ "tex/latex/textpos/")
+ (base32
+ "1g208dx853xg7g72jggkh13934r49yypksvalm5pk6snh0s0k86c")
+ #:trivial? #t))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/textpos")
+ (synopsis "Absolute positioning of text on the LaTeX page")
+ (description
+ "This package facilitates placing boxes at absolute positions on the
+LaTeX page. There are several reasons why this might be useful, but the main
+one (or at least my motivating one) is to help produce a large-format
+conference poster.
+
+This package provides a single environment, plus a starred variant, which
+contains the text (or graphics, or table, or whatever) which is to be placed
+on the page, and which specifies where it is to be placed. The environment is
+accompanied by various configuration commands.")
+ (license license:lppl)))
+
(define-public bibtool
(package
(name "bibtool")