summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-24 21:50:03 +0200
committerMarius Bakke <marius@gnu.org>2021-06-06 00:12:53 +0200
commitbf84be15a8ccb3cd16a9fa61bf58394980790448 (patch)
tree52be91c8c82c41a66c3197324b5686753dabc523 /gnu/packages/tex.scm
parent80c3374f0527e56f32dd209709181eafb9e52d7d (diff)
downloadguix-patches-bf84be15a8ccb3cd16a9fa61bf58394980790448.tar
guix-patches-bf84be15a8ccb3cd16a9fa61bf58394980790448.tar.gz
gnu: texlive-latex-tools: Provide array-2016-10-06.sty.
* gnu/packages/tex.scm (texlive-latex-tools)[arguments]: Add phase that makes array.sty available with a different name.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0a5887a0a8..39cc4e9f37 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3268,7 +3268,19 @@ files have changed. It is based on MD5 checksum, provided by pdfTeX.")
(build-system texlive-build-system)
(arguments
'(#:tex-directory "latex/tools"
- #:build-targets '("tools.ins")))
+ #:build-targets '("tools.ins")
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'provide-array-2016-10-06.sty
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; XXX: array.sty does:
+ ;; "DeclareRelease{}{2016-10-06}{array-2016-10-06.sty}"
+ ;; ...which causes some users (hypre) to look for that
+ ;; file specifically. Provide it.
+ (with-directory-excursion (string-append
+ (assoc-ref outputs "out")
+ "/share/texmf-dist/tex"
+ "/latex/tools")
+ (symlink "array.sty" "array-2016-10-06.sty")))))))
(home-page "https://www.ctan.org/pkg/latex-tools")
(synopsis "LaTeX standard tools bundle")
(description