summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-13 17:09:30 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-13 22:49:56 +0200
commitf98dfdc1b6d73e0b9f3f45c74942289bbefd7b34 (patch)
tree0d1aa0da86c357d87f3b1081d82c4e1213a433c8 /gnu/packages/tex.scm
parente668a9b11df536c67c2f364088b85482d5c9a96d (diff)
downloadguix-patches-f98dfdc1b6d73e0b9f3f45c74942289bbefd7b34.tar
guix-patches-f98dfdc1b6d73e0b9f3f45c74942289bbefd7b34.tar.gz
gnu: Add texlive-context.
* gnu/packages/tex.scm (texlive-context): New variable. (texlive-context-base): Deprecate in favor of texlive-context. * gnu/packages/chez.scm (chez-web)[native-inputs]: Replace texlive-context-base with texlive-context.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm113
1 files changed, 88 insertions, 25 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bb0a1cc2ff..c15203c1f2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7291,32 +7291,92 @@ Support for use with LaTeX is available in @code{freenfss}, part of
(define-public texlive-fonts-charter
(deprecated-package "texlive-fonts-charter" texlive-charter))
-(define-public texlive-context-base
+(define-public texlive-context
(package
- (name "texlive-context-base")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/context/base"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0d7d74giz5knvj4rj6mbzd6c05mwg9jrxab86jxdqbc3jy7cl4kz"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/context/case")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
+ (inherit (simple-texlive-package
+ "texlive-context"
+ (list "/doc/context/"
+ "/doc/man/man1/context.1"
+ "/doc/man/man1/luatools.1"
+ "/doc/man/man1/mtx-babel.1"
+ "/doc/man/man1/mtx-base.1"
+ "/doc/man/man1/mtx-bibtex.1"
+ "/doc/man/man1/mtx-cache.1"
+ "/doc/man/man1/mtx-chars.1"
+ "/doc/man/man1/mtx-check.1"
+ "/doc/man/man1/mtx-colors.1"
+ "/doc/man/man1/mtx-context.1"
+ "/doc/man/man1/mtx-dvi.1"
+ "/doc/man/man1/mtx-epub.1"
+ "/doc/man/man1/mtx-evohome.1"
+ "/doc/man/man1/mtx-fcd.1"
+ "/doc/man/man1/mtx-flac.1"
+ "/doc/man/man1/mtx-fonts.1"
+ "/doc/man/man1/mtx-grep.1"
+ "/doc/man/man1/mtx-interface.1"
+ "/doc/man/man1/mtx-metapost.1"
+ "/doc/man/man1/mtx-modules.1"
+ "/doc/man/man1/mtx-package.1"
+ "/doc/man/man1/mtx-pdf.1"
+ "/doc/man/man1/mtx-plain.1"
+ "/doc/man/man1/mtx-profile.1"
+ "/doc/man/man1/mtx-rsync.1"
+ "/doc/man/man1/mtx-scite.1"
+ "/doc/man/man1/mtx-server.1"
+ "/doc/man/man1/mtx-texworks.1"
+ "/doc/man/man1/mtx-timing.1"
+ "/doc/man/man1/mtx-tools.1"
+ "/doc/man/man1/mtx-unicode.1"
+ "/doc/man/man1/mtx-unzip.1"
+ "/doc/man/man1/mtx-update.1"
+ "/doc/man/man1/mtx-watch.1"
+ "/doc/man/man1/mtx-youless.1"
+
+
+ "/bibtex/bst/context/"
+ "/context/"
+
+ "/fonts/afm/hoekwater/context/contnav.afm"
+ "/fonts/cid/fontforge/Adobe-CNS1-4.cidmap"
+ "/fonts/cid/fontforge/Adobe-GB1-4.cidmap"
+ "/fonts/cid/fontforge/Adobe-Identity-0.cidmap"
+ "/fonts/cid/fontforge/Adobe-Japan1-5.cidmap"
+ "/fonts/cid/fontforge/Adobe-Japan1-6.cidmap"
+ "/fonts/cid/fontforge/Adobe-Japan2-0.cidmap"
+ "/fonts/cid/fontforge/Adobe-Korea1-2.cidmap"
+ "/fonts/enc/dvips/context/"
+ "/fonts/map/dvips/context/"
+ "/fonts/map/luatex/context/"
+ "/fonts/map/pdftex/context/"
+ "/fonts/misc/xetex/fontmapping/context/"
+ "/fonts/tfm/hoekwater/context/"
+ "/fonts/type1/hoekwater/context/"
+ "/metapost/context/"
+ "/scripts/context/"
+ "/tex/context/base/"
+ "/tex/context/bib/"
+ "/tex/context/colors/"
+ "/tex/context/fonts/"
+ "/tex/context/interface/"
+ "/tex/context/modules/"
+ "/tex/context/patterns/"
+ "/tex/context/sample/"
+ "/tex/context/test/"
+ "/tex/context/user/"
+ "/tex/generic/context/"
+ "/tex/latex/context/")
+ (base32
+ "1npaw9jy41iv9qiilbmcljvc28rjzyjkan6mfcxizv2sbirymwp1")
+ #:trivial? #t))
+ ;; TODO: add these missing packages:
+ ;; xetex, luatex, lm-math, manfnt-font, and mptopdf
+ (propagated-inputs
+ `(("texlive-amsfonts" ,texlive-amsfonts)
+ ("texlive-lm" ,texlive-lm)
+ ("texlive-pdftex" ,texlive-pdftex)
+ ("texlive-metapost" ,texlive-metapost)
+ ("texlive-fonts-stmaryrd" ,texlive-fonts-stmaryrd)
+ ("texlive-mflogo-font" ,texlive-mflogo-font)))
(home-page "https://www.ctan.org/pkg/context")
(synopsis "Full featured, parameter driven macro package for TeX")
(description "A full featured, parameter driven macro package, which fully
@@ -7324,6 +7384,9 @@ supports advanced interactive documents. See the ConTeXt garden for a wealth
of support information.")
(license license:gpl2+)))
+(define-public texlive-context-base
+ (deprecated-package "texlive-context-base" texlive-context))
+
(define-public texlive-beamer
(package
(inherit (simple-texlive-package