summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-10 22:41:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:15 +0200
commite0d307d154f852d9d34af90a0586b38e7864af78 (patch)
treeef3134ab6bb5a4326234ab3e0fefdfdd74f80077 /gnu/packages/tex.scm
parent0de81b09a9217cf6e061b1a8a81692f4bdf6a5ad (diff)
downloadguix-patches-e0d307d154f852d9d34af90a0586b38e7864af78.tar
guix-patches-e0d307d154f852d9d34af90a0586b38e7864af78.tar.gz
gnu: Add texlive-latex-parskip.
* gnu/packages/tex.scm (texlive-latex-parskip): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 235213e686..a2a9867af1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2845,6 +2845,40 @@ the included graphic. LaTeX commands can be placed on the graphic at defined
positions; a grid for orientation is available.")
(license license:lppl1.0+)))
+(define-public texlive-latex-parskip
+ (package
+ (name "texlive-latex-parskip")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/parskip"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "14r6h9hqb0qgccxj5l1208694fx8sb8avmgzps36lsbbpszl7i7m"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/parskip")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/parskip")
+ (synopsis "Layout with zero \\parindent, non-zero \\parskip")
+ (description
+ "Simply changing @code{\\parskip} and @code{\\parindent} leaves a layout
+that is untidy; this package (though it is no substitute for a properly
+designed class) helps alleviate this untidiness.")
+ (license license:lppl)))
+
(define-public texlive-latex-pdfpages
(package
(name "texlive-latex-pdfpages")