summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 12:51:57 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-19 13:11:40 -0400
commit5e2140511c1ad9ccd731438b74d61b62111da1e6 (patch)
treea4ff748ad26e121b88469b5d921001ef1382be8f /gnu/packages/terminals.scm
parent9e3a5ee417ea7fe9721be8804ff047e80c4f22ed (diff)
parent353bdae32f72b720c7ddd706576ccc40e2b43f95 (diff)
downloadguix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar
guix-patches-5e2140511c1ad9ccd731438b74d61b62111da1e6.tar.gz
Merge branch 'staging'
Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/gdb.scm gnu/packages/llvm.scm gnu/packages/package-management.scm gnu/packages/tls.scm
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm44
1 files changed, 26 insertions, 18 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 57c84d7718..e596c1b81f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crypto)
#:use-module (gnu packages docbook)
#:use-module (gnu packages fontutils)
@@ -220,24 +221,29 @@ text-based approach to terminal recording.")
(package
(name "libtsm")
(version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- ;; The freedesktop repository is no longer maintained.
- (uri (git-reference
- (url (string-append "https://github.com/Aetf/" name))
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0mwn91i5h5d518i1s05y7hzv6bc13vzcvxszpfh77473iwg4wprx"))))
+ (source
+ (origin
+ (method git-fetch)
+ ;; The freedesktop repository is no longer maintained.
+ (uri (git-reference
+ (url (string-append "https://github.com/Aetf/" name))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mwn91i5h5d518i1s05y7hzv6bc13vzcvxszpfh77473iwg4wprx"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove a bundled copy of libxkbcommon's xkbcommon-keysyms.h.
+ (delete-file-recursively "external/xkbcommon")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("libxkbcommon" ,libxkbcommon)
- ("check" ,check)))
+ `(("check" ,check)
+ ("libxkbcommon" ,libxkbcommon) ; for xkbcommon-keysyms.h
+ ("pkg-config" ,pkg-config)))
(synopsis "Xterm state machine library")
(description "TSM is a state machine for DEC VT100-VT520 compatible
terminal emulators. It tries to support all common standards while keeping
@@ -426,7 +432,7 @@ to all types of devices that provide serial consoles.")
allowing different sounds to indicate different events. While it can be run
quite happily on the command line, its intended place of residence is within
scripts, notifying the user when something interesting occurs. Of course, it
-has no notion of what's interesing, but it's very good at that notifying part.")
+has no notion of what's interesting, but it's very good at that notifying part.")
(home-page "https://github.com/spkr-beep/beep")
(license license:gpl2+)))
@@ -731,7 +737,7 @@ programmer to write text-based user interfaces.")
(define-public go-github-com-junegunn-fzf
(package
(name "go-github-com-junegunn-fzf")
- (version "0.18.0")
+ (version "0.22.0")
(source
(origin
(method git-fetch)
@@ -741,7 +747,7 @@ programmer to write text-based user interfaces.")
(file-name (git-file-name name version))
(sha256
(base32
- "0pwpr4fpw56yzzkcabzzgbgwraaxmp7xzzmap7w1xsrkbj7dl2xl"))))
+ "0n0cy5q2r3dm1a3ivlzrv9c5d11awxlqim5b9x8zc85dlr73n35l"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/junegunn/fzf"))
@@ -750,6 +756,8 @@ programmer to write text-based user interfaces.")
("go-github-com-mattn-go-shellwords" ,go-github-com-mattn-go-shellwords)
("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
("go-github-com-gdamore-tcell" ,go-github-com-gdamore-tcell)
+ ("go-github-com-saracen-walker" ,go-github-com-saracen-walker)
+ ("go-golang.org-x-sync-errgroup" ,go-golang.org-x-sync-errgroup)
("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
(home-page "https://github.com/junegunn/fzf")
(synopsis "Command-line fuzzy-finder")
@@ -1175,7 +1183,7 @@ made by suckless.")
("rust-mio" ,rust-mio-0.6)
("rust-mio-extras" ,rust-mio-extras-2)
("rust-terminfo" ,rust-terminfo-0.6)
- ("rust-url" ,rust-url-2.1)
+ ("rust-url" ,rust-url-2)
("rust-vte" ,rust-vte-0.3)
("rust-nix" ,rust-nix-0.15)
("rust-miow" ,rust-miow-0.3)