summaryrefslogtreecommitdiff
path: root/gnu/packages/telephony.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-07-24 23:53:17 +0200
committerMarius Bakke <marius@gnu.org>2020-07-24 23:53:17 +0200
commitcbe96f14700f4805552c47d5f163a75c35f86575 (patch)
treed7791d29b283507bb8953a292d764b24774c955c /gnu/packages/telephony.scm
parent337333c2567bdf767fdc8e04520c4bc0c8b33784 (diff)
parent7a9a27a051a04a7fee2e7fe40127fedbe9112cfd (diff)
downloadguix-patches-cbe96f14700f4805552c47d5f163a75c35f86575.tar
guix-patches-cbe96f14700f4805552c47d5f163a75c35f86575.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/telephony.scm')
-rw-r--r--gnu/packages/telephony.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 4c84ddc85a..4c5e4d5d78 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -102,7 +102,7 @@
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/TimothyGu/libilbc.git")
+ (url "https://github.com/TimothyGu/libilbc")
(commit
(string-append "v" version))))
(file-name
@@ -297,7 +297,7 @@ packet-manipulation library.")
(method git-fetch)
(uri
(git-reference
- (url "https://github.com/wernerd/ZRTPCPP.git")
+ (url "https://github.com/wernerd/ZRTPCPP")
(commit
(string-append "V" version))))
(file-name
@@ -588,6 +588,16 @@ address of one of the participants.")
(substitute* "src/mumble/Settings.cpp"
(("bUsage = true;") "bUsage = false;"))
#t))
+ (add-before 'configure 'fix-mumble-overlay
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-output-to-file "scripts/mumble-overlay"
+ (lambda ()
+ (format #t "#!~a~%" (which "bash"))
+ (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
+ (string-append (assoc-ref outputs "out")
+ "/lib/mumble/libmumble.so.1"))
+ (format #t "exec \"${@}\"")))
+ #t))
(add-before 'install 'disable-murmur-ice
(lambda _
(substitute* "scripts/murmur.ini.system"
@@ -717,7 +727,7 @@ your calls and messages.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/pjsip/pjproject.git")
+ (url "https://github.com/pjsip/pjproject")
(commit version)))
(file-name (git-file-name name version))
(sha256
@@ -803,7 +813,7 @@ Initiation Protocol (SIP) and a multimedia framework.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/grishka/libtgvoip.git")
+ (url "https://github.com/grishka/libtgvoip")
(commit version)))
(file-name (git-file-name name version))
;; Fix compilation on i686-linux architecture.