summaryrefslogtreecommitdiff
path: root/gnu/packages/tcsh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
commit1289062522e3d08259740e59243c6cd0642a9916 (patch)
tree65857ae41001e3b33db621073cf1504de601dda1 /gnu/packages/tcsh.scm
parentcb4d3d863b3fb44d97b3b568ff9e6cfe38f1f630 (diff)
parentda699774d4d839a45daa3ae3b9189331c490b315 (diff)
downloadguix-patches-1289062522e3d08259740e59243c6cd0642a9916.tar
guix-patches-1289062522e3d08259740e59243c6cd0642a9916.tar.gz
Merge branch 'core-updates'.
Diffstat (limited to 'gnu/packages/tcsh.scm')
-rw-r--r--gnu/packages/tcsh.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/tcsh.scm b/gnu/packages/tcsh.scm
index f582713911..814f2a6321 100644
--- a/gnu/packages/tcsh.scm
+++ b/gnu/packages/tcsh.scm
@@ -58,7 +58,11 @@
(("; other_script.csh") "; /bin/sh other_script.csh"))
;; Now, let's generate the test suite and patch it
(system* "make" "tests/testsuite")
- (substitute* "tests/testsuite" (("/bin/sh") (which "sh"))))
+
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "tests/testsuite"
+ (("/bin/sh") (which "sh")))))
(alist-cons-after
'install 'post-install
(lambda* (#:key inputs outputs #:allow-other-keys)