summaryrefslogtreecommitdiff
path: root/gnu/packages/tcl.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-06-26 18:29:23 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:12:53 +0200
commit2ce30a37ad5d74e368a8db4a1f38877ee9759a02 (patch)
tree035cceb406cd709cff65ce6ae8bdbe27e8ba6285 /gnu/packages/tcl.scm
parent57ec9861f45784a16a469d8bfaf0792969a45455 (diff)
downloadguix-patches-2ce30a37ad5d74e368a8db4a1f38877ee9759a02.tar
guix-patches-2ce30a37ad5d74e368a8db4a1f38877ee9759a02.tar.gz
gnu: tcl: Fix cross-compilation.
* gnu/packages/tcl.scm (tcl)[arguments]: Add configure flags to fix cross-compilation.
Diffstat (limited to 'gnu/packages/tcl.scm')
-rw-r--r--gnu/packages/tcl.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 21ca185066..96f41e7928 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -53,7 +53,7 @@
"0kjzj7mkzfnb7ksxanbibibfpciyvsh5ffdlhs0bmfc75kgd435d"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
(add-before 'configure 'pre-configure
(lambda _ (chdir "unix") #t))
(add-after 'install 'install-private-headers
@@ -73,9 +73,16 @@
;; PREFIX/share/man. The 'validate-documentation-location' phase is
;; not able to fix this up because the default install populates both
;; PREFIX/man and PREFIX/share/man.
- #:configure-flags (list (string-append "--mandir="
- (assoc-ref %outputs "out")
- "/share/man"))
+ #:configure-flags
+ (list (string-append "--mandir="
+ (assoc-ref %outputs "out")
+ "/share/man")
+ ;; This is needed when cross-compiling, see:
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=719247
+ ,@(if (%current-target-system)
+ '("tcl_cv_strtod_buggy=1"
+ "ac_cv_func_strtod=yes")
+ '()))
;; XXX: There are a few test failures (related to HTTP, most
;; likely related to name resolution), but that doesn't cause