summaryrefslogtreecommitdiff
path: root/gnu/packages/tbb.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 10:07:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 11:47:09 -0500
commit276f40fdc349d2ad62582b23ea55e061b689cfc0 (patch)
tree8052d91aee78cf0d4317b41ec52134fde48fa5fb /gnu/packages/tbb.scm
parentb2f6b6f6b9df6bcc24794238e7e97357470af95d (diff)
parent6ba510d76d6847065be725e958718002f3b13c7a (diff)
downloadguix-patches-276f40fdc349d2ad62582b23ea55e061b689cfc0.tar
guix-patches-276f40fdc349d2ad62582b23ea55e061b689cfc0.tar.gz
Merge branch 'version-1.4.0'
With resolved conflicts in: gnu/packages/gnome.scm gnu/packages/openstack.scm gnu/packages/python-xyz.scm
Diffstat (limited to 'gnu/packages/tbb.scm')
-rw-r--r--gnu/packages/tbb.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index 427f281686..e5d8394f5f 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -89,7 +89,8 @@ tasks, synchronization primitives, atomic operations, and more.")
(arguments
`(#:test-target "test"
#:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib"))
+ (assoc-ref %outputs "out") "/lib")
+ "CFLAGS=-fuse-ld=gold")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fail-on-test-errors
@@ -121,6 +122,13 @@ tasks, synchronization primitives, atomic operations, and more.")
(copy-recursively "doc" doc)
(copy-recursively "examples" examples)
(copy-recursively "include" include)))))))
+ (native-inputs
+ ;; XXX: For some reason, since commit "gnu: binutils: Absorb
+ ;; binutils-next", the build of just this version of TBB crashes during
+ ;; tests. Workaround it by linking the binaries with ld.gold.
+ (list (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'ld-gold-wrapper)))
(home-page "https://www.threadingbuildingblocks.org")
(synopsis "C++ library for parallel programming")
(description