summaryrefslogtreecommitdiff
path: root/gnu/packages/task-management.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-19 19:14:50 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-09-22 10:57:08 +0200
commit1f2076757a043c8b0c0af3a6faf249c650756dfc (patch)
treeaa3f1317d0c5eeabc4206fb0a77a0551109e0f0e /gnu/packages/task-management.scm
parent69a5738796de88dbf63334dd76c952586b1852ae (diff)
downloadguix-patches-1f2076757a043c8b0c0af3a6faf249c650756dfc.tar
guix-patches-1f2076757a043c8b0c0af3a6faf249c650756dfc.tar.gz
gnu: Add blanket.
* gnu/packages/task-management.scm (blanket): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/task-management.scm')
-rw-r--r--gnu/packages/task-management.scm68
1 files changed, 67 insertions, 1 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index 601a3616f7..3c0efe13e2 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
+;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,11 +20,22 @@
(define-module (gnu packages task-management)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
+ #:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
+ #:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages tls)
#:use-module (guix download)
- #:use-module (guix build-system cmake))
+ #:use-module (guix git-download)
+ #:use-module (guix utils)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system meson))
(define-public taskwarrior
(package
@@ -59,3 +71,57 @@
Done time management method. It supports network synchronization, filtering
and querying data, exposing task data in multiple formats to other tools.")
(license license:expat)))
+
+(define-public blanket
+ (package
+ (name "blanket")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rafaelmardojai/blanket/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13xip9b2p2ai2jchkck71c849s2rlxzfvlbsgpraw9hswi0rk0jg"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:tests? #f ;the "Validate appstream file" test fails
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'wrap 'wrap-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
+ (python-path (getenv "PYTHONPATH")))
+ (wrap-program (string-append out "/bin/blanket")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
+ `("PYTHONPATH" ":" prefix (,python-path))))
+ #t)))))
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gst-plugins-bad" ,gst-plugins-bad)
+ ("gst-plugins-good" ,gst-plugins-good) ;for ScaleTempo plugin
+ ("gtk+" ,gtk+)
+ ("libhandy" ,libhandy)
+ ("python-gst" ,python-gst)
+ ("python-pygobject" ,python-pygobject)))
+ (home-page "https://github.com/rafaelmardojai/blanket")
+ (synopsis "Ambient sound and noise player")
+ (description
+ "Blanket provides different ambient sounds and types of noise to listen
+to with the goal of improving your focus and enhancing your productivity.
+You can also use it to fall asleep in a noisy environment.")
+ (license license:gpl3+)))