summaryrefslogtreecommitdiff
path: root/gnu/packages/system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
commita22dc0c49aed0babe16ef92ae24847b343b7eb02 (patch)
tree2d1ce88952d68274437dc07fbffbea688bc0eea3 /gnu/packages/system.scm
parent668d48a6847bcdc69d2c6e6aa44090f566ecd05b (diff)
downloadguix-patches-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar
guix-patches-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar.gz
Synchronize package descriptions with the Womb.
* gnu/packages/algebra.scm, gnu/packages/aspell.scm, gnu/packages/autotools.scm, gnu/packages/base.scm, gnu/packages/bash.scm, gnu/packages/bison.scm, gnu/packages/cdrom.scm, gnu/packages/cflow.scm, gnu/packages/compression.scm, gnu/packages/cpio.scm, gnu/packages/cppi.scm, gnu/packages/ddrescue.scm, gnu/packages/dejagnu.scm, gnu/packages/ed.scm, gnu/packages/emacs.scm, gnu/packages/fdisk.scm, gnu/packages/freeipmi.scm, gnu/packages/gawk.scm, gnu/packages/gcal.scm, gnu/packages/gcc.scm, gnu/packages/gdb.scm, gnu/packages/gdbm.scm, gnu/packages/gettext.scm, gnu/packages/ghostscript.scm, gnu/packages/global.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnutls.scm, gnu/packages/gperf.scm, gnu/packages/gprolog.scm, gnu/packages/groff.scm, gnu/packages/grub.scm, gnu/packages/gsasl.scm, gnu/packages/guile.scm, gnu/packages/gv.scm, gnu/packages/help2man.scm, gnu/packages/idutils.scm, gnu/packages/indent.scm, gnu/packages/less.scm, gnu/packages/libidn.scm, gnu/packages/libsigsegv.scm, gnu/packages/libunistring.scm, gnu/packages/lightning.scm, gnu/packages/linux.scm, gnu/packages/lsh.scm, gnu/packages/m4.scm, gnu/packages/mail.scm, gnu/packages/maths.scm, gnu/packages/multiprecision.scm, gnu/packages/nano.scm, gnu/packages/ncurses.scm, gnu/packages/nettle.scm, gnu/packages/ocrad.scm, gnu/packages/oggvorbis.scm, gnu/packages/parted.scm, gnu/packages/plotutils.scm, gnu/packages/pth.scm, gnu/packages/readline.scm, gnu/packages/recutils.scm, gnu/packages/rush.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/shishi.scm, gnu/packages/smalltalk.scm, gnu/packages/system.scm, gnu/packages/texinfo.scm, gnu/packages/time.scm, gnu/packages/unrtf.scm, gnu/packages/version-control.scm, gnu/packages/wdiff.scm, gnu/packages/wget.scm, gnu/packages/which.scm, gnu/packages/xnee.scm, gnu/packages/zile.scm: Change value of the 'description' field to that of the Womb.
Diffstat (limited to 'gnu/packages/system.scm')
-rw-r--r--gnu/packages/system.scm39
1 files changed, 11 insertions, 28 deletions
diff --git a/gnu/packages/system.scm b/gnu/packages/system.scm
index 6f710fd4d4..a5d2e67585 100644
--- a/gnu/packages/system.scm
+++ b/gnu/packages/system.scm
@@ -51,13 +51,11 @@
(inputs `(("pkg-config" ,pkg-config)
("guile" ,guile-2.0)))
(synopsis "Daemon managing daemons")
- (description "'DMD' is a \"Daemon managing Daemons\" (or
-\"Daemons-managing Daemon\"?)---i.e. a service manager that provides a
-replacement for the service-managing capabilities of SysV-init (or any other
-init) with a both powerful and beautiful dependency-based system with a
-convenient interface. It is intended for use on GNU/Hurd, but it is supposed
-to work on every POSIX-like system where Guile is available. In particular,
-it has been tested on GNU/Linux.")
+ (description
+ "DMD is a \"daemon-managing daemon,\" meaning it manages the execution of
+system services, replacing similar functionality found in typical init
+systems. It provides dependency-handling through a convenient interface and
+is based on GNU Guile.")
(license gpl3+)
(home-page "http://www.gnu.org/software/dmd/")))
@@ -120,23 +118,10 @@ application (for console or X terminals) and requires ncurses.")
(home-page "http://www.gnu.org/software/pies/")
(synopsis "Program invocation and execution supervisor")
(description
- "The name Pies (pronounced \"p-yes\") stands for Program Invocation
-and Execution Supervisor. This utility starts and controls execution of
-external programs, called components. Each component is a stand-alone
-program, which is executed in the foreground. Upon startup, pies reads
-the list of components from its configuration file, starts them, and
-remains in the background, controlling their execution. If any of the
-components terminates, the default action of Pies is to restart it.
-However, it can also be programmed to perform a variety of another
-actions such as, e.g., sending mail notifications to the system
-administrator, invoking another external program, etc.
-
-Pies can be used for a wide variety of tasks. Its most obious use is to
-put in backgound a program which normally cannot detach itself from the
-controlling terminal, such as, e.g., minicom. It can launch and control
-components of some complex system, such as Jabberd or MeTA1 (and it
-offers much more control over them than the native utilities). Finally,
-it can replace the inetd utility!")
+ "Pies is a program that supervises the invocation and executiton of
+other programs. It reads the list of programs to be started from its
+configuration file, executes them, and then monitors their status,
+re-executing them as necessary.")
(license gpl3+)))
(define-public inetutils
@@ -160,10 +145,8 @@ it can replace the inetd utility!")
(home-page "http://www.gnu.org/software/inetutils/")
(synopsis "Basic networking utilities")
(description
- "The GNU network utilities suite provides the following tools:
-ftp(d), hostname, ifconfig, inetd, logger, ping, rcp, rexec(d),
-rlogin(d), rsh(d), syslogd, talk(d), telnet(d), tftp(d), traceroute,
-uucpd, and whois.")
+ "Inetutils is a collection of common network programs, such as an ftp
+client and server, a telnet client and server, and an rsh client and server.")
(license gpl3+)))
(define-public shadow