summaryrefslogtreecommitdiff
path: root/gnu/packages/synergy.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2020-07-03 14:05:18 -0500
committerEric Bavier <bavier@member.fsf.org>2020-07-03 14:06:42 -0500
commit2ca4ae2993e20a1415fa25acf8fd6b993ee48c18 (patch)
tree6345c03111d41c065d5f1e120eb0186e3b130bc0 /gnu/packages/synergy.scm
parentec70df7243b8d0892d8cec7a43a87c9740c4bfaa (diff)
downloadguix-patches-2ca4ae2993e20a1415fa25acf8fd6b993ee48c18.tar
guix-patches-2ca4ae2993e20a1415fa25acf8fd6b993ee48c18.tar.gz
gnu: Update synergy to 1.11.1.
* gnu/packages/synergy.scm (synergy): Update to 1.11.1. [arguments]: Add "patch-desktop" phase. [native-inputs]: New field. [inputs]: Remove unused "xinput" input.
Diffstat (limited to 'gnu/packages/synergy.scm')
-rw-r--r--gnu/packages/synergy.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 739ea3bd75..4db15527d7 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -37,17 +37,17 @@
(define-public synergy
(package
(name "synergy")
- (version "1.11.0")
+ (version "1.11.1")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/symless/synergy-core.git")
- (commit (string-append version "-stable"))))
+ (commit (string-append "v" version "-stable"))))
(file-name (git-file-name name version))
(sha256
(base32
- "1jk60xw4h6s5crha89wk4y8rrf1f3bixgh5mzh3cq3xyrkba41gh"))
+ "0dn0h3mdqy0mbg4yyhsh4rhvvsssqlknnln3naplc97my10lk2a0"))
(modules '((guix build utils)))
(snippet
;; Remove unnecessary bundled source and binaries
@@ -65,7 +65,15 @@
(string-append (assoc-ref inputs "avahi")
"/include/avahi-compat-libdns_sd:"
(or (getenv "CPLUS_INCLUDE_PATH") "")))
- #t)))))
+ #t))
+ (add-after 'install 'patch-desktop
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/share/applications/synergy.desktop")
+ (("/usr") out))
+ #t))))))
+ (native-inputs
+ `(("qttools" ,qttools))) ; for Qt5LinguistTools
(inputs
`(("avahi" ,avahi)
("python" ,python-wrapper)
@@ -74,7 +82,6 @@
("libxi" ,libxi)
("libx11" ,libx11)
("libxtst" ,libxtst)
- ("xinput" ,xinput)
("qtbase" ,qtbase)))
(home-page "https://symless.com/synergy")
(synopsis "Mouse and keyboard sharing utility")