summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorTimo Wilken <guix@twilken.net>2023-04-21 21:55:13 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 10:45:56 -0400
commit4976208fa8aa4b5b63f51285ca5fff841a20bdba (patch)
tree0298f5f17492c82fd80ed0eb59925bbf54804d71 /gnu/packages/syncthing.scm
parenta61b08ffa70793708ce0bd3f425381f87067f6c4 (diff)
downloadguix-patches-4976208fa8aa4b5b63f51285ca5fff841a20bdba.tar
guix-patches-4976208fa8aa4b5b63f51285ca5fff841a20bdba.tar.gz
gnu: Move golang dependencies to (gnu packages golang).
These packages are needed by syncthing and the new restic-rest-server package, so put them in (gnu packages golang) instead. * gnu/packages/syncthing.scm (go-github-com-prometheus-common, go-github-com-prometheus-procfs, go-github-com-prometheus-client-golang): Move variables ... * gnu/packages/golang.scm (go-github-com-prometheus-common, go-github-com-prometheus-procfs, go-github-com-prometheus-client-golang): ... to here. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm90
1 files changed, 0 insertions, 90 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index c4204f32fe..dd54100ce6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -877,96 +877,6 @@ message streaming.")
(home-page "https://github.com/matttproud/golang_protobuf_extensions")
(license asl2.0))))
-(define-public go-github-com-prometheus-common
- (package
- (name "go-github-com-prometheus-common")
- (version "0.4.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/common")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0sf4sjdckblz1hqdfvripk3zyp8xq89w7q75kbsyg4c078af896s"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/common"
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-golang-protobuf-proto
- go-github-com-matttproud-golang-protobuf-extensions-pbutil
- go-github-com-prometheus-client-model))
- (synopsis "Prometheus metrics")
- (description "This package provides tools for reading and writing
-Prometheus metrics.")
- (home-page "https://github.com/prometheus/common")
- (license asl2.0)))
-
-(define-public go-github-com-prometheus-procfs
- (package
- (name "go-github-com-prometheus-procfs")
- (version "0.0.4")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/procfs")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z5jq5rjala0a0di4nwk1rai0z9f73qwqj6mgcbpjbg2qknlb544"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/prometheus/procfs"
- ;; The tests require Go modules, which are not yet supported in Guix's
- ;; Go build system.
- #:tests? #f))
- (synopsis "Go library for reading @file{/proc}")
- (description "The @code{procfs} Go package provides functions to retrieve
-system, kernel, and process metrics from the @file{/proc} pseudo file system.")
- (home-page "https://github.com/prometheus/procfs")
- (license asl2.0)))
-
-(define-public go-github-com-prometheus-client-golang
- (package
- (name "go-github-com-prometheus-client-golang")
- (version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/client_golang")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0zs49psk23n9z8wrl02d5vib5wclpym8kaxcy6n5pk696i419065"))))
- (build-system go-build-system)
- (arguments
- '(#:tests? #f
- #:import-path "github.com/prometheus/client_golang"
- #:phases
- (modify-phases %standard-phases
- ;; Source-only package
- (delete 'build))))
- (propagated-inputs
- (list go-github-com-beorn7-perks-quantile
- go-github-com-golang-protobuf-proto
- go-github-com-prometheus-client-model
- go-github-com-prometheus-common
- go-github-com-prometheus-procfs
- go-github-com-cespare-xxhash))
- (synopsis "HTTP server and client tools for Prometheus")
- (description "This package @code{promhttp} provides HTTP client and
-server tools for Prometheus metrics.")
- (home-page "https://github.com/prometheus/client_golang")
- (license asl2.0)))
-
(define-public go-github-com-go-asn1-ber-asn1-ber
(package
(name "go-github-com-go-asn1-ber-asn1-ber")