summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-28 20:19:45 -0500
committerLeo Famulari <leo@famulari.name>2018-02-08 15:18:21 -0500
commitfa22168b5ced52ccc31046b8e8fcd2aea76e7705 (patch)
treeb54c7c2014050501b40e132bca2aadd5b871c0ab /gnu/packages/syncthing.scm
parentbfbe868d8e2ee9000a0cbe9c32b1c08dea595134 (diff)
downloadguix-patches-fa22168b5ced52ccc31046b8e8fcd2aea76e7705.tar
guix-patches-fa22168b5ced52ccc31046b8e8fcd2aea76e7705.tar.gz
gnu: Add go-github-com-client-golang-prometheus.
* gnu/packages/syncthing.scm (go-github-com-client-golang-prometheus): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index fec8d532ad..1087bcba0b 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -2141,3 +2141,42 @@ system, kernel and process metrics from the pseudo-filesystem @file{/proc}.")
server tools for Prometheus metrics.")
(home-page "https://github.com/prometheus/client_golang")
(license asl2.0))))
+
+(define-public go-github-com-client-golang-prometheus
+ (let ((commit "180b8fdc22b4ea7750bcb43c925277654a1ea2f3")
+ (revision "0"))
+ (package
+ (name "go-github-com-prometheus-client-golang-prometheus")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_golang.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kkfx1j9ka18ydsmdi2cdy3hs39c22b39mbc4laykmj2x93lmbdp"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/client_golang/prometheus"
+ #:unpack-path "github.com/prometheus/client_golang"))
+ (propagated-inputs
+ `(("go-github-com-beorn7-perks-quantile"
+ ,go-github-com-beorn7-perks-quantile)
+ ("go-github-com-golang-protobuf-proto"
+ ,go-github-com-golang-protobuf-proto)
+ ("go-github-com-prometheus-client-model-go"
+ ,go-github-com-prometheus-client-model-go)
+ ("go-github-com-prometheus-common-expfmt"
+ ,go-github-com-prometheus-common-expfmt)
+ ("go-github-com-prometheus-procfs" ,go-github-com-prometheus-procfs)
+ ("go-github-com-client-golang-prometheus-promhttp"
+ ,go-github-com-client-golang-prometheus-promhttp)))
+ (synopsis "Prometheus instrumentation library for Go applications")
+ (description "This package provides the Go client library for the
+Prometheus monitoring and alerting system. It has two separate parts, one for
+instrumenting application code, and one for creating clients that talk to the
+Prometheus HTTP API.")
+ (home-page "https://github.com/prometheus/client_golang")
+ (license asl2.0))))