summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-30 16:16:26 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 01:22:03 -0800
commit27fbcae6d57a49ff0ee0218e95c87e801d84fdb3 (patch)
tree579dcbb42890d617ef955e54999adbbf5d4470d9 /gnu/packages/syncthing.scm
parente62d057505de7961d23431778e851d5133bcfc36 (diff)
downloadguix-patches-27fbcae6d57a49ff0ee0218e95c87e801d84fdb3.tar
guix-patches-27fbcae6d57a49ff0ee0218e95c87e801d84fdb3.tar.gz
gnu: kcp-go: Switch upstream source.
* gnu/packages/syncthing.scm (go-github-com-audriusbutkevicius-kcp-go): Replace with ... (go-github-com-xtaci-kcp-go): ... new variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 8f6b1f5052..0f524e5c80 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -118,8 +118,8 @@
(inputs
`(("go-github-com-audriusbutkevicius-cli"
,go-github-com-audriusbutkevicius-cli)
- ("go-github-com-audriusbutkevicius-kcp-go"
- ,go-github-com-audriusbutkevicius-kcp-go)
+ ("go-github-com-xtaci-kcp-go"
+ ,go-github-com-xtaci-kcp-go)
("go-github-com-audriusbutkevicius-go-nat-pmp"
,go-github-com-audriusbutkevicius-go-nat-pmp)
("go-github-com-audriusbutkevicius-pfilter"
@@ -1581,33 +1581,34 @@ rolling hash.")
(home-page "https://github.com/chmduquesne/rollinghash")
(license expat))))
-(define-public go-github-com-audriusbutkevicius-kcp-go
- (let ((commit "8ae5f528469c6ab76110f41eb7a51341b7efb946")
- (revision "1"))
+(define-public go-github-com-xtaci-kcp-go
+ (let ((commit "86eebd5cadb519b7c9306082c7eb3bcee2c49a7b")
+ (revision "0"))
(package
- (name "go-github-com-audriusbutkevicius-kcp-go")
+ (name "go-github-com-xtaci-kcp-go")
(version (git-version "0.0.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/AudriusButkevicius/kcp-go")
+ (url "https://github.com/xtaci/kcp-go")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32
- "1bhg7bfc0r4a7i516xasq3i5ln15lsalm7i53b4nchba6db7mq14"))))
+ "1mdfsya4y04nycfgsk9ghm67zpim5pw78si3f1566xgrv4ghl0ni"))))
(build-system go-build-system)
(propagated-inputs
`(("go-golang-org-x-net-ipv4" ,go-golang-org-x-net-ipv4)
- ("go-github-com-templexxx-reedsolomon"
- ,go-github-com-templexxx-reedsolomon)
+ ("go-github-com-klauspost-reedsolomon"
+ ,go-github-com-klauspost-reedsolomon)
("go-github-com-tjfoc-gmsm-sm4" ,go-github-com-tjfoc-gmsm-sm4)
("go-github-com-pkg-errors" ,go-github-com-pkg-errors)
("go-golang-org-x-crypto" ,(go-golang-org-x-crypto-union))
("go-github-com-templexxx-xor" ,go-github-com-templexxx-xor)))
(arguments
- '(#:import-path "github.com/AudriusButkevicius/kcp-go"
+ '(#:import-path "github.com/xtaci/kcp-go"
+ ;; XXX update comment
;; 'TestListenerClose' is known to fail. It seems that the test suite
;; is not being used upstream:
;; https://github.com/AudriusButkevicius/kcp-go/pull/1