summaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-09 02:19:00 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-03-10 00:19:49 +0100
commit82a2f182c59cd9adef4991e0adfb575fec95e52d (patch)
treebd82f3bee4b933823352a865764babf7846aff16 /gnu/packages/sync.scm
parent92a432c1f83f1929ae41fb53c1cf9910836e6b3a (diff)
downloadguix-patches-82a2f182c59cd9adef4991e0adfb575fec95e52d.tar
guix-patches-82a2f182c59cd9adef4991e0adfb575fec95e52d.tar.gz
gnu: Add nextcloud-client.
* gnu/packages/messaging.scm (nextcloud-client): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/sync.scm')
-rw-r--r--gnu/packages/sync.scm154
1 files changed, 154 insertions, 0 deletions
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index d7c9009f3b..2b64117dc6 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -30,6 +30,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system meson)
+ #:use-module (guix build-system qt)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix packages)
@@ -42,8 +43,11 @@
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages linux)
@@ -52,15 +56,165 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages python-xyz)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages rsync)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages selinux)
#:use-module (gnu packages shells)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages tls))
+(define-public nextcloud-client
+ (package
+ (name "nextcloud-client")
+ (version "3.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/nextcloud/desktop")
+ (commit (string-append "v" version))))
+ (file-name
+ (git-file-name name version))
+ (sha256
+ (base32 "15ymk3gvfmgwzmqbhlw7jjy9y65ib3391h1dlmpll65iaj2miajk"))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-1)))
+ (snippet
+ '(begin
+ ;; Not available in Guix.
+ (let* ((keep '("QProgressIndicator" "qtokenizer")))
+ (with-directory-excursion "src/3rdparty"
+ (for-each delete-file-recursively
+ (lset-difference string=?
+ (scandir ".")
+ (cons* "." ".." keep)))))
+ (with-directory-excursion "src/gui"
+ (substitute* "CMakeLists.txt"
+ ;; Remove references of deleted 3rdparties.
+ (("[ \t]*\\.\\./3rdparty/qtlockedfile/?.*\\.cpp")
+ "")
+ (("[ \t]*\\.\\./3rdparty/qtsingleapplication/?.*\\.cpp")
+ "")
+ (("[ \t]*\\.\\./3rdparty/kmessagewidget/?.*\\.cpp")
+ "")
+ (("[ \t]*list\\(APPEND 3rdparty_SRC \\.\\./3rdparty/?.*\\)")
+ "")
+ (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/qtlockedfile")
+ "")
+ (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/qtsingleapplication")
+ "")
+ (("\\$\\{CMAKE_SOURCE_DIR\\}/src/3rdparty/kmessagewidget")
+ ;; For this, we rely on build inputs, so let's just replace
+ ;; them by an autoconf-style variable.
+ "@kwidgetsaddons@")
+ ;; Expand libraries, that used to be statically linked, but
+ ;; no longer are post-vendoring.
+ (("\\$\\{synclib_NAME\\}")
+ (string-append "${synclib_NAME} "
+ "QtSolutions_LockedFile "
+ "QtSolutions_SingleApplication "
+ "KF5WidgetsAddons")))
+ ;; Fix compatibility with QtSingleApplication from QtSolutions.
+ (substitute* '("application.h" "application.cpp")
+ (("SharedTools::QtSingleApplication")
+ "QtSingleApplication")
+ (("slotParseMessage\\(const QString &(msg)?.*\\)")
+ "slotParseMessage(const QString &msg)")))
+ #t))))
+ (build-system qt-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DUNIT_TESTING=ON"
+ ;; Upstream Bug: https://github.com/nextcloud/desktop/issues/2885
+ "-DNO_SHIBBOLETH=ON")
+ #:imported-modules
+ ((guix build glib-or-gtk-build-system)
+ ,@%qt-build-system-modules)
+ #:modules
+ (((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
+ (guix build qt-build-system)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-cmake
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Patch install directory for dbus service files.
+ (substitute* "shell_integration/libcloudproviders/CMakeLists.txt"
+ (("PKGCONFIG_GETVAR\\(.+ _install_dir\\)")
+ (string-append "set(_install_dir \"${CMAKE_INSTALL_PREFIX}"
+ "/share/dbus-1/services\")")))
+ (substitute* "shell_integration/dolphin/CMakeLists.txt"
+ ;; Make sure, that Qt modules are installed under $prefix.
+ (("ON CACHE") "OFF CACHE"))
+ (substitute* "src/gui/CMakeLists.txt"
+ (("@kwidgetsaddons@")
+ (string-append (assoc-ref inputs "kwidgetsaddons")
+ "/include/KF5/KWidgetsAddons/")))
+ #t))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ #t))
+ (add-after 'install 'glib-or-gtk-compile-schemas
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+ (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
+ (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+ (native-inputs
+ `(("cmocka" ,cmocka)
+ ("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("glib:bin" ,glib "bin")
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("qttools" ,qttools)
+ ("ruby" ,ruby)))
+ (inputs
+ `(("appstream" ,appstream)
+ ("desktop-file-utils" ,desktop-file-utils)
+ ("glib" ,glib)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kjs" ,kjs)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("libcloudproviders" ,libcloudproviders)
+ ("libzip" ,libzip)
+ ("openssl" ,openssl)
+ ("python-nautilus" ,python-nautilus)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtkeychain" ,qtkeychain)
+ ("qtquickcontrols2" ,qtquickcontrols2)
+ ("qtsolutions" ,qtsolutions)
+ ("qtsvg" ,qtsvg)
+ ("qtwebchannel" ,qtwebchannel)
+ ("qtwebsockets" ,qtwebsockets)
+ ("qtwebkit" ,qtwebkit)
+ ("sqlite" ,sqlite)
+ ("xdg-utils" ,xdg-utils)
+ ("zlib" ,zlib)))
+ (propagated-inputs
+ `(("qtwebengine" ,qtwebengine)))
+ (synopsis "Desktop sync client for Nextcloud")
+ (description "Nextcloud-Desktop is a tool to synchronize files from
+Nextcloud Server with your computer.")
+ (home-page "https://nextcloud.com")
+ (license (list license:expat ; QProgressIndicator
+ license:lgpl2.1+ ; qtokenizer
+ license:gpl2+))))
+
(define-public megacmd
(package
(name "megacmd")