summaryrefslogtreecommitdiff
path: root/gnu/packages/swig.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/swig.scm
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
downloadguix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar
guix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/swig.scm')
-rw-r--r--gnu/packages/swig.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 61f6a8ccfe..b1b17fc68d 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,7 +51,14 @@
;; Required since Perl 5.26.0's removal of the current
;; working directory from @INC.
;; TODO Try removing this for later versions of SWIG.
- (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
+ (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t))
+ (add-before 'configure 'workaround-gcc-bug
+ (lambda _
+ ;; XXX: Don't add the -isystem flag, or GCCs #include_next
+ ;; won't be able to find <stdlib.h>.
+ (substitute* "configure"
+ (("-isystem ") "-I"))
+ #t)))))
(native-inputs `(("boost" ,boost)
("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(;; Provide these to run the corresponding tests.