summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-29 21:34:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-29 21:49:12 +0100
commit0811f0f9d298a4ef3965d94157427abe39b8f5a7 (patch)
treee6f686cf81bec9028126a28569b5750f062fc88f /gnu/packages/statistics.scm
parentca380feb371e831a4ce0a17fb6d3e1e5135322bb (diff)
downloadguix-patches-0811f0f9d298a4ef3965d94157427abe39b8f5a7.tar
guix-patches-0811f0f9d298a4ef3965d94157427abe39b8f5a7.tar.gz
gnu: Add r-base64.
* gnu/packages/statistics.scm (r-base64): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 69f4b94405..746c90e121 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3485,6 +3485,28 @@ definition of Surv objects, Kaplan-Meier and Aalen-Johansen (multi-state)
curves, Cox models, and parametric accelerated failure time models.")
(license license:lgpl2.0+)))
+(define-public r-base64
+ (package
+ (name "r-base64")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "base64" version))
+ (sha256
+ (base32
+ "1labh0ycdm2xcjssj8bhnyjvbk44mcdsi0rb2p8rfqa428mrq9cf"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-openssl" ,r-openssl)))
+ (home-page "http://cran.r-project.org/web/packages/base64")
+ (synopsis "Base64 encoder and decoder")
+ (description
+ "This package is a compatibility wrapper to replace the orphaned package
+by Romain Francois. New applications should use the openssl or base64enc
+package instead.")
+ (license license:expat)))
+
(define-public r-hmisc
(package
(name "r-hmisc")