summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:57:21 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:28:59 +0100
commit5c31f4aa7c11fcf720c0ce0e26d55788e2df1044 (patch)
treeedfc0e7f53c478a9c15f4f1c15e24c2a10cdd194 /gnu/packages/statistics.scm
parent00e10c6e674f0f292d5821bc4a513d48f4d1d164 (diff)
downloadguix-patches-5c31f4aa7c11fcf720c0ce0e26d55788e2df1044.tar
guix-patches-5c31f4aa7c11fcf720c0ce0e26d55788e2df1044.tar.gz
gnu: Remove python-setuptools and python2-setuptools from inputs (part 4a)
This patch contains the changes for all modules beside python.scm where setuptools are used in an inherited package and removing this input also removes the need for inheriting the package. This is the case if adding setuptools in the inherited package was the only change. Change this to not inherit and remove the new needless call to "strip-python2-variant (if applicable). * gnu/packages/bioinformatics.scm (python-biopython, python2-biopython, python-twobitreader, python2-twobitreader, python-plastid, python2-plastid, python2-pybigwig, python2-screed, sra-tools): No longer "inherit" Python 2 packages inheriting from a Python 3 package if the sole reason for inheriting was adding python-setuptools respective python2-setuptools to [inputs], [native-inputs] or [propagated-inputs]. Remove now needless [properties] "python2-variant" where applicable. * gnu/packages/django.scm (python-pytest-django, python2-pytest-django, python-django-filter, python2-django-filter): Likewise. * gnu/packages/gnupg.scm (python2-pygpgme): Likewise. * gnu/packages/mail.scm (python-mailmanclient, python2-mailmanclient): Likewise. * gnu/packages/mpd.scm (python-msp, python2-mpd2): Likewise. * gnu/packages/music.scm (python-pylast, python2-pylast): Likewise. * gnu/packages/openstack.scm (python-requests-mock, python2-requests-mock, python2-git-review): Likewise. * gnu/packages/password-utils.scm (python2-bcrypt): Likewise. * gnu/packages/protobuf.scm (python-protobuf, python2-protobuf): Likewise. * gnu/packages/statistics.scm (python-patsy, python2-patsy): Likewise. * gnu/packages/web.scm (python2-feedparser): Likewise.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index a19d6000d4..950c3ec64f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1416,15 +1416,10 @@ building design matrices.")
;; The majority of the code is distributed under BSD-2. The module
;; patsy.compat contains code derived from the Python standard library,
;; and is covered by the PSFL.
- (license (list license:bsd-2 license:psfl))
- (properties `((python2-variant . ,(delay python2-patsy))))))
+ (license (list license:bsd-2 license:psfl))))
(define-public python2-patsy
- (let ((patsy (package-with-python2 (strip-python2-variant python-patsy))))
- (package (inherit patsy)
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs patsy))))))
+ (package-with-python2 python-patsy))
(define-public python-statsmodels
(package