summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-05-18 14:09:52 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-05-26 14:05:16 +0200
commite53ecc60871e97517be27e11a3d88d059ec36777 (patch)
tree869e3b1bfd7146990d20c3832e7d3b1be7897be2 /gnu/packages/statistics.scm
parent6c7aafbedf656ff7cacf39141c649b82abcd7bf7 (diff)
downloadguix-patches-e53ecc60871e97517be27e11a3d88d059ec36777.tar
guix-patches-e53ecc60871e97517be27e11a3d88d059ec36777.tar.gz
gnu: Add r-logspline.
* gnu/packages/statistics.scm (r-logspline): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 27df2091ee..6318efdda1 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -6155,3 +6155,29 @@ or eta squared effect size.")
(description
"Weighted k-Nearest Neighbors for Classification, Regression and Clustering.")
(license license:gpl2+)))
+
+(define-public r-logspline
+ (package
+ (name "r-logspline")
+ (version "2.1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "logspline" version))
+ (sha256
+ (base32
+ "12hkdi77vkic05p2vhap025xdcg1n53ywm239v18713pihdlj63l"))))
+ (properties `((upstream-name . "logspline")))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page
+ "https://cran.r-project.org/web/packages/logspline/")
+ (synopsis
+ "Routines for Logspline Density Estimation")
+ (description
+ "Contains routines for logspline density estimation. The function
+@code{oldlogspline()} uses the same algorithm as the logspline package version
+1.0.x; i.e. the Kooperberg and Stone (1992) algorithm (with an improved
+interface). The recommended routine @code{logspline()} uses an algorithm from
+@url{doi:10.1214/aos/1031594728,Stone et al (1997)}.")
+ (license license:asl2.0)))