summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-04 09:40:41 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-11-07 22:34:34 +0000
commit108111114d5269e608f961d44955d0d4613b9c15 (patch)
tree251ea5267c42151fca32e2c5873ab7a91596dad8 /gnu/packages/statistics.scm
parent17d0bbef88501126f13f9b60aa74d3c912c853ed (diff)
downloadguix-patches-108111114d5269e608f961d44955d0d4613b9c15.tar
guix-patches-108111114d5269e608f961d44955d0d4613b9c15.tar.gz
gnu: r-with-tests: Remove trailing #T.
* gnu/packages/statistics.scm (r-with-tests)[arguments]: Remove trailing #T from build phases.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 038258a8bc..eb6898e60d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -215,8 +215,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
;; This ensures that Guix can detect embedded store references;
;; see bug #28157 for details.
(substitute* "src/library/base/makebasedb.R"
- (("compress = TRUE") "compress = FALSE"))
- #t))
+ (("compress = TRUE") "compress = FALSE"))))
(add-before 'configure 'patch-coreutils-paths
(lambda* (#:key inputs #:allow-other-keys)
(let* ((coreutils (assoc-ref inputs "coreutils"))
@@ -225,8 +224,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(substitute* "src/scripts/R.sh.in"
(("uname") uname-bin))
(substitute* "src/unix/sys-std.c"
- (("rm -Rf ") (string-append rm-bin " -Rf "))))
- #t))
+ (("rm -Rf ") (string-append rm-bin " -Rf "))))))
(add-after 'unpack 'build-reproducibly
(lambda _
;; The documentation contains time stamps to demonstrate
@@ -285,17 +283,15 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
;; that is suspected to be the culprit.
(substitute* "src/library/methods/DESCRIPTION.in"
(("\\(2008\\)\n") "(2008) ")
- ((" ``Software") "``Software"))
- #t))
+ ((" ``Software") "``Software"))))
(add-before 'build 'set-locales
(lambda _
(setlocale LC_ALL "C")
- (setenv "LC_ALL" "C")
- #t))
+ (setenv "LC_ALL" "C")))
(add-before 'configure 'set-default-pager
;; Set default pager to "cat", because otherwise it is "false",
;; making "help()" print nothing at all.
- (lambda _ (setenv "PAGER" "cat") #t))
+ (lambda _ (setenv "PAGER" "cat")))
(add-before 'check 'set-timezone
;; Some tests require the timezone to be set. However, the
;; timezone may not just be "UTC", or else a brittle regression
@@ -304,8 +300,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(setenv "TZ" "UTC+1")
(setenv "TZDIR"
(string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
- #t))
+ "/share/zoneinfo"))))
(add-after 'build 'make-info
(lambda _ (invoke "make" "info")))
(add-after 'build 'install-info