summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:07 +0200
commitb25e18407b0ad8a848d6c9619b500a359470e70a (patch)
tree95b763313370db31917980d8341646b41a416980 /gnu/packages/ssh.scm
parentb8d5cbb767d587e39fc3537a8606c872948ed192 (diff)
downloadguix-patches-b25e18407b0ad8a848d6c9619b500a359470e70a.tar
guix-patches-b25e18407b0ad8a848d6c9619b500a359470e70a.tar.gz
gnu: hss: Use G-expressions.
* gnu/packages/ssh.scm (hss)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 58dd55de2a..2e2be68770 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -72,6 +72,7 @@
#:use-module (guix build-system python)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
@@ -93,18 +94,18 @@
(inputs
(list readline))
(arguments
- `(#:make-flags
- (list ,(string-append "CC=" (cc-for-target))
- (string-append "INSTALL_BIN=" (assoc-ref %outputs "out") "/bin"))
- #:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-file-names
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/usr/local/opt/readline")
- (assoc-ref inputs "readline")))))
- (delete 'configure)))) ; no configure script
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "INSTALL_BIN=" #$output "/bin"))
+ #:tests? #f ; no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-names
+ (lambda _
+ (substitute* "Makefile"
+ (("/usr/local/opt/readline")
+ #$(this-package-input "readline")))))
+ (delete 'configure)))) ; no configure script
(build-system gnu-build-system)
(home-page "https://github.com/six-ddc/hss/")
(synopsis "Interactive SSH client for multiple servers")