summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorAhmad Jarara <git@ajarara.io>2021-11-05 14:12:56 -0400
committerLudovic Courtès <ludo@gnu.org>2021-12-01 17:53:27 +0100
commit8cc099b4250589c0d23fc6762868f6542433f143 (patch)
tree402180afcdddad8fcc6ad56555e4e97f16d816b6 /gnu/packages/ssh.scm
parent3aaef047a6fdf02b1db0f4d53d445d6f7809171e (diff)
downloadguix-patches-8cc099b4250589c0d23fc6762868f6542433f143.tar
guix-patches-8cc099b4250589c0d23fc6762868f6542433f143.tar.gz
gnu: openssh: Add support for ecdsa-sk, ed25519-sk ssh keys.
* gnu/packages/ssh.scm (openssh)[inputs]: Add LIBFIDO2. [arguments]: Pass "--with-security-key-builtin". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index a681945f8e..616f6dc915 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -63,6 +63,7 @@
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages security-token)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages xorg)
@@ -199,6 +200,7 @@ a server that supports the SSH-2 protocol.")
(native-inputs `(("groff" ,groff)
("pkg-config" ,pkg-config)))
(inputs `(("libedit" ,libedit)
+ ("libfido2" ,libfido2)
("openssl" ,openssl)
,@(if (hurd-target?)
'()
@@ -229,6 +231,9 @@ a server that supports the SSH-2 protocol.")
'()
'("--with-pam"))
+ ;; supports creation and use of ecdsa-sk, ed25519-sk keys
+ "--with-security-key-builtin"
+
;; "make install" runs "install -s" by default,
;; which doesn't work for cross-compiled binaries
;; because it invokes 'strip' instead of