summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/ssh.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm43
1 files changed, 41 insertions, 2 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index ca99235a01..9f60b3c02e 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -520,7 +520,7 @@ TCP, not the SSH protocol.")
(define-public dropbear
(package
(name "dropbear")
- (version "2020.80")
+ (version "2020.81")
(source
(origin
(method url-fetch)
@@ -528,7 +528,7 @@ TCP, not the SSH protocol.")
"https://matt.ucc.asn.au/dropbear/releases/"
"dropbear-" version ".tar.bz2"))
(sha256
- (base32 "0jbrbpdzyv11x5rkljdimzq9p6a7da5siw9k405ibnpjj4dr89yr"))))
+ (base32 "0fy5ma4cfc2pk25mcccc67b2mf1rnb2c06ilb7ddnxbpnc85s8s8"))))
(build-system gnu-build-system)
(arguments `(#:tests? #f)) ; there is no "make check" or anything similar
;; TODO: Investigate unbundling libtommath and libtomcrypt or at least
@@ -793,6 +793,45 @@ dynamically loadable modules for extended functionality such as new remote
shell services and remote host selection.")
(license license:gpl2+)))
+(define-public python-asyncssh
+ (package
+ (name "python-asyncssh")
+ (version "2.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asyncssh" version))
+ (sha256
+ (base32
+ "0pi6npmsgx7l9r1qrfvg8mxx3i23ipff492xz4yhrw13f56a7ga4"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-pyopenssl" ,python-pyopenssl)
+ ("python-gssapi" ,python-gssapi)
+ ("python-bcrypt" ,python-bcrypt)))
+ (native-inputs
+ `(("openssh" ,openssh)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-tests
+ (lambda* _
+ (substitute* "tests/test_agent.py"
+ ;; TODO Test fails for unknown reason
+ (("(.+)async def test_confirm" all indent)
+ (string-append indent "@unittest.skip('disabled by guix')\n"
+ indent "async def test_confirm")))
+ #t)))))
+ (home-page "https://asyncssh.readthedocs.io/")
+ (synopsis "Asynchronous SSHv2 client and server library for Python")
+ (description
+ "AsyncSSH is a Python package which provides an asynchronous client and
+server implementation of the SSHv2 protocol on top of the Python 3.6+ asyncio
+framework.")
+ (license license:epl2.0)))
+
(define-public clustershell
(package
(name "clustershell")