summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 17:31:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-03-27 17:42:52 +0200
commit10c95711b4ec69706377bd0f3db86f1cf2bb047a (patch)
tree550cc1f7bbd71e745553f87fb4d02e13a660e277 /gnu/packages/ssh.scm
parent040ae44aa1fb42b8e801b2abbebc8ec869eaaa65 (diff)
downloadguix-patches-10c95711b4ec69706377bd0f3db86f1cf2bb047a.tar
guix-patches-10c95711b4ec69706377bd0f3db86f1cf2bb047a.tar.gz
gnu: corkscrew: Improve descriptions.
* gnu/packages/ssh.scm (corkscrew)[synopsis, description]: Fix typos and condense. Remove scary warning (the tunnel is always encrypted through SSH) and speculation.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 67ffe1fac2..b5c73ea85e 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -292,12 +292,11 @@ libssh library.")
(string-append "." "/configure")
flags))))))))
(home-page "http://www.agroman.net/corkscrew")
- (synopsis "Tunneling SSH through HTTP proxies")
+ (synopsis "SSH tunneling through HTTP(S) proxies")
(description
- "Corkscrew allows creating TCP tunnels through HTTP proxies. WARNING:
-At the moment only plain text authentication is supported, should you require
-to use it with your HTTP proxy. Digest based authentication may be supported
-in future and NTLM based authentication is most likey never be supported.")
+ "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
+Proxy authentication is only supported through the plain-text HTTP basic
+authentication scheme.")
(license license:gpl2+)))
(define-public mosh