summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-03 06:39:37 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-03 06:39:37 +0100
commit759a526f5fdd49b9136a639269afd77e2599dcb6 (patch)
tree891bebc0fec814fb0e64e2463998b4b61a1963a2 /gnu/packages/ssh.scm
parent4bb9bb78c2482627b1afa2cffda68a4427a3b21d (diff)
downloadguix-patches-759a526f5fdd49b9136a639269afd77e2599dcb6.tar
guix-patches-759a526f5fdd49b9136a639269afd77e2599dcb6.tar.gz
gnu: openssh: Update to 8.5p1.
* gnu/packages/patches/openssh-fix-ssh-copy-id.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Also unregister it. * gnu/packages/ssh.scm (openssh): Update to 8.5p1.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index c94631036b..b73e9633ea 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -186,16 +186,15 @@ a server that supports the SSH-2 protocol.")
(define-public openssh
(package
(name "openssh")
- (version "8.4p1")
+ (version "8.5p1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
"openssh-" version ".tar.gz"))
- (patches (search-patches "openssh-hurd.patch"
- "openssh-fix-ssh-copy-id.patch"))
+ (patches (search-patches "openssh-hurd.patch"))
(sha256
(base32
- "091b3pxdlj47scxx6kkf4agkx8c8sdacdxx8m1dw1cby80pd40as"))))
+ "09gc8rv7728chxraab85dzkdikaw4aph1wlcwcc9kai9si0kybzm"))))
(build-system gnu-build-system)
(native-inputs `(("groff" ,groff)
("pkg-config" ,pkg-config)))