summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-29 16:15:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-05 15:17:26 +0200
commit227dbd841a630034a508ccd2718609a5113a0a5d (patch)
tree55bbc8b03d93745f68e2ab795885d52671768f1f /gnu/packages/ssh.scm
parent04717e9406f3b5171ad28ed67d926ce0e25da94d (diff)
downloadguix-patches-227dbd841a630034a508ccd2718609a5113a0a5d.tar
guix-patches-227dbd841a630034a508ccd2718609a5113a0a5d.tar.gz
gnu: Add pdsh.
* gnu/packages/ssh.scm (pdsh): New variable.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 1dac85d74a..8317f29cd8 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -603,3 +604,40 @@ monitor it, restarting it as necessary should it die or stop passing traffic.")
;; copy of this license in their headers, but there's no separate file
;; with that information.
(license:non-copyleft "file://autossh.c"))))
+
+(define-public pdsh
+ (package
+ (name "pdsh")
+ (version "2.29")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://storage.googleapis.com/"
+ "google-code-archive-downloads/v2/code.google.com/"
+ "pdsh/pdsh-" version ".tar.bz2"))
+ (sha256
+ (base32 "1kvzz01fyaxfqmbh53f4ljfsgvxdykh5jyr6fh4f1bw2ywxr1w2p"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--with-ssh")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-/bin/sh
+ (lambda _
+ (substitute* '("tests/runtests.sh"
+ "tests/test-lib.sh"
+ "tests/test-modules/pcptest.c")
+ (("/bin/sh") (which "bash")))
+ #t)))))
+ (inputs
+ `(("openssh" ,openssh)
+ ("mit-krb5" ,mit-krb5)
+ ("perl" ,perl)))
+ (home-page "https://code.google.com/archive/p/pdsh")
+ (synopsis "Parallel distributed shell")
+ (description "Pdsh is a an efficient, multithreaded remote shell client
+which executes commands on multiple remote hosts in parallel. Pdsh implements
+dynamically loadable modules for extended functionality such as new remote
+shell services and remote host selection.")
+ (license license:gpl2+)))