summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-11 19:14:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-11 21:07:24 +0200
commit96fe62d80e18da54a0989643ac53849c45d1f89e (patch)
tree0b5f0818052557d16bc459e34eccf609c77dd33c /gnu/packages/ssh.scm
parent6018d1ee600787d36ccc39af3fe35e5b167e310b (diff)
downloadguix-patches-96fe62d80e18da54a0989643ac53849c45d1f89e.tar
guix-patches-96fe62d80e18da54a0989643ac53849c45d1f89e.tar.gz
gnu: hss: Move to (gnu packages ssh).
* gnu/packages/admin.scm (hss): Move… * gnu/packages/ssh.scm (hss): …here.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 38b98f1c5b..1ffb74be3f 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -70,6 +71,53 @@
#:use-module (guix utils)
#:use-module (srfi srfi-1))
+(define-public hss
+ (package
+ (name "hss")
+ (version "1.8")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/six-ddc/hss.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rpysj65j9ls30bf2c5k5hykzzjfknrihs58imp178bx1wqzw4jl"))))
+ (inputs
+ `(("readline" ,readline)))
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-env
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/usr/local/bin")
+ (string-append (assoc-ref outputs "out") "/bin"))
+ (("/usr/local/opt/readline")
+ (assoc-ref inputs "readline")))
+ (setenv "CC" "gcc")))
+ (delete 'configure))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/six-ddc/hss/")
+ (synopsis "Interactive SSH client for multiple servers")
+ (description "@command{hss} is an interactive SSH client for multiple
+servers. It will provide almost the same experience as in the Bash
+environment. It supports:
+
+@itemize @bullet
+@item interactive input: based on @code{libreadline}.
+@item history: responding to the @key{C-r} key.
+@item auto-completion: completion from remote server on the @key{TAB} key, for
+commands and paths.
+@end itemize
+
+Command is executed on all servers in parallel. Execution on one server does
+not need to wait for that on another server to finish before starting. So we
+can run a command on hundreds of servers at the same time.")
+ (license license:expat)))
+
(define-public libssh
(package
(name "libssh")