summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-29 17:34:41 +0200
commit5576cfabf3485e0cf794cc3de085a3578151ee64 (patch)
tree8ca4093d05fda6b0064d0fca429353327ec491f9 /gnu/packages/spice.scm
parent12cb6c31df4b90d58658e88a256e36b6808e1064 (diff)
parente086d2f68b90a39bae07ae46572e5cc6b0fc4308 (diff)
downloadguix-patches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar
guix-patches-5576cfabf3485e0cf794cc3de085a3578151ee64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index fb3b11ba2d..521be54c49 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -86,6 +86,10 @@
(modify-phases %standard-phases
(add-after 'unpack 'autogen
(lambda _
+ ;; Build without '-Werror', in particular to avoid errors due
+ ;; to the use of the deprecated 'libusb_set_debug' function.
+ (substitute* "configure.ac"
+ (("-Werror") ""))
(zero? (system* "autoreconf" "-vfi")))))))
(synopsis "Tools for sending USB device traffic over a network")
(description "Usbredir is a network protocol for sending USB device traffic