summaryrefslogtreecommitdiff
path: root/gnu/packages/sphinx.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-03 09:14:43 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-03 09:57:35 +0000
commite740cc614096e768813280c718f9e96343ba41b3 (patch)
tree25ade70a5d408be80f62f19c6511172aab7dcce5 /gnu/packages/sphinx.scm
parent1b9186828867e77af1f2ee6741063424f8256398 (diff)
parent63cf277bfacf282d2b19f00553745b2a9370eca0 (diff)
downloadguix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar
guix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/sphinx.scm')
-rw-r--r--gnu/packages/sphinx.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7da42d958c..cbf0d21f51 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -439,6 +439,30 @@ theme for the Sphinx documentation system. It's the default theme of Sphinx.")
(define-public python2-sphinx-alabaster-theme
(package-with-python2 python-sphinx-alabaster-theme))
+(define-public python-sphinx-argparse
+ (package
+ (name "python-sphinx-argparse")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinx-argparse" version))
+ (sha256
+ (base32 "05wc8f5hb3jsg2vh2jf7jsyan8d4i09ifrz2c8fp6f7x1zw9iav0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-sphinx" ,python-sphinx)))
+ (native-inputs
+ `(("python-commonmark" ,python-commonmark)
+ ("python-pytest" ,python-pytest)
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
+ (home-page "https://github.com/ribozz/sphinx-argparse")
+ (synopsis "Sphinx extension for documenting argparse commands and options")
+ (description
+ "This package is a sphinx extension that automatically documents
+argparse commands and options")
+ (license license:expat)))
+
(define-public python-sphinx-cloud-sptheme
(package
(name "python-sphinx-cloud-sptheme")