summaryrefslogtreecommitdiff
path: root/gnu/packages/simulation.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-22 20:25:48 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-06 15:23:06 +0200
commit9d5160bc8af8bea7eae77ba785574936cd3945be (patch)
tree8314beb68c9aaa3cbb009bff9430abeeeeac1656 /gnu/packages/simulation.scm
parent69505bec93ef7e7c79b7ed619e15a19845618a23 (diff)
downloadguix-patches-9d5160bc8af8bea7eae77ba785574936cd3945be.tar
guix-patches-9d5160bc8af8bea7eae77ba785574936cd3945be.tar.gz
gnu: fenics: Honor #:tests? flag.
* gnu/packages/simulation.scm (fenics)[arguments]: Adjust custom 'check' phase to honor the #:tests? flag. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/simulation.scm')
-rw-r--r--gnu/packages/simulation.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 757738e627..230ae62826 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -657,17 +657,18 @@ user interface to the FEniCS core components and external libraries.")
;; Restrict OpenBLAS to MPI-only in preference to MPI+OpenMP.
(setenv "OPENBLAS_NUM_THREADS" "1")))
(replace 'check
- (lambda _
- (with-directory-excursion "test"
- ;; Note: The test test_snes_set_from_options() in the file
- ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
- ;; Limit the number of jobs to 3 as 500 MiB of memory is used
- ;; per process.
- (invoke "mpirun" "-np" (number->string
- (min 3 (parallel-job-count)))
- "python" "-B" "-m"
- "pytest" "unit" "--ignore"
- "unit/nls/test_PETScSNES_solver.py"))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ ;; Note: The test test_snes_set_from_options() in the file
+ ;; unit/nls/test_PETScSNES_solver.py fails and is ignored.
+ ;; Limit the number of jobs to 3 as 500 MiB of memory is used
+ ;; per process.
+ (invoke "mpirun" "-np" (number->string
+ (min 3 (parallel-job-count)))
+ "python" "-B" "-m"
+ "pytest" "unit" "--ignore"
+ "unit/nls/test_PETScSNES_solver.py")))))
(add-after 'install 'install-demo-files
(lambda* (#:key outputs #:allow-other-keys)
(let* ((demos (string-append