summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/shellutils.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadguix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar
guix-patches-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 56359ce160..f7542ea759 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -25,7 +25,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages golang)
#:use-module (gnu packages python)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -61,8 +61,7 @@
(synopsis "Save and restore environment variables")
(description "Envstore is a program for sharing environment variables
between various shells or commands.")
- (license
- (non-copyleft "http://www.wtfpl.net/txt/copying/"))))
+ (license license:wtfpl2)))
(define-public trash-cli
(package
@@ -98,7 +97,7 @@ between various shells or commands.")
FreeDesktop.org trash can used by GNOME, KDE, XFCE, and other common desktop
environments. It can move files to the trash, and remove or list files that
are already there.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public direnv
(package
@@ -151,7 +150,7 @@ allows project-specific environment variables without using @file{~/.profile}.
Before each prompt, direnv checks for the existence of a @file{.envrc} file in
the current and parent directories. This file is then used to alter the
environment variables of the current shell.")
- (license expat)))
+ (license license:expat)))
(define-public fzy
(package
@@ -186,7 +185,7 @@ or different parts of the path.
fzy is designed to be used both as an editor plugin and on the command
line. Rather than clearing the screen, fzy displays its interface directly
below the current cursor position, scrolling the screen if necessary.")
- (license expat)))
+ (license license:expat)))
(define-public hstr
(package
@@ -228,4 +227,4 @@ HSTR can also manage your command history (for instance you can remove
commands that are obsolete or contain a piece of sensitive information) or
bookmark your favourite commands.")
(home-page "http://me.mindforger.com/projects/hh.html")
- (license asl2.0)))
+ (license license:asl2.0)))