summaryrefslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-10-29 06:53:28 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-30 19:12:40 +0200
commitbcce83c7857d226a053a8563fc4e326a47fca473 (patch)
treebcccf1e120d192eb11b5493da0f9e0c1b5a43265 /gnu/packages/shellutils.scm
parentd4449565ed90aabaa6b755dfe1786a1dce370707 (diff)
downloadguix-patches-bcce83c7857d226a053a8563fc4e326a47fca473.tar
guix-patches-bcce83c7857d226a053a8563fc4e326a47fca473.tar.gz
gnu: Add Random Identity Generator (rig)
* gnu/packages/shellutils.scm (rig): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/shellutils.scm')
-rw-r--r--gnu/packages/shellutils.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index 3ded0ee897..6e64cee1da 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Alexandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -463,3 +464,51 @@ the UNIX philosophy, these commands are designed to be composed via pipes. A
large collection of functions such as basename, replace, contains or is_dir
are provided as arguments to these commands.")
(license license:expat)))
+
+(define-public rig
+ (package
+ (name "rig")
+ (version "1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/rig/rig/"
+ version "/rig-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1f3snysjqqlpk2kgvm5p2icrj4lsdymccmn3igkc2f60smqckgq0"))))
+ (build-system gnu-build-system)
+ (arguments `(#:make-flags
+ (list (string-append "CXX=" ,(cxx-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-build
+ (lambda _
+ (substitute* "rig.cc"
+ (("^#include <string>")
+ "#include <cstring>"))
+ (substitute* "Makefile"
+ (("g\\+\\+")
+ "${CXX} -O2")
+ (("install -g 0 -m 755 -o 0 -s rig \\$\\(BINDIR\\)")
+ "install -m 755 -d $(DESTDIR)$(BINDIR)\n\t\
+install -m 755 rig $(DESTDIR)$(BINDIR)/rig")
+ (("install -g 0 -m 644 -o 0 rig.6 \\$\\(MANDIR\\)/man6/rig.6")
+ "install -m 755 -d $(DESTDIR)$(MANDIR)/man6/\n\t\
+install -m 644 rig.6 $(DESTDIR)$(MANDIR)/man6/rig.6")
+ (("install -g 0 -m 755 -o 0 -d \\$\\(DATADIR\\)")
+ "install -m 755 -d $(DESTDIR)$(DATADIR)")
+ (("install -g 0 -m 644 -o 0 data/\\*.idx \\$\\(DATADIR\\)")
+ "install -m 644 data/*.idx $(DESTDIR)$(DATADIR)")))))
+ #:tests? #f))
+ (home-page "http://rig.sourceforge.net")
+ (synopsis "Random identity generator")
+ (description
+ "RIG (Random Identity Generator) generates random, yet real-looking,
+personal data. It is useful if you need to feed a name to a Web site, BBS, or
+real person, and are too lazy to think of one yourself. Also, if the Web
+site/BBS/person you are giving the information to tries to cross-check the
+city, state, zip, or area code, it will check out.")
+ (license license:gpl2+)))